[backfire] merge r21903
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 26 Jun 2010 18:12:10 +0000 (18:12 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 26 Jun 2010 18:12:10 +0000 (18:12 +0000)
SVN-Revision: 21904

package/ppp/Makefile
package/ppp/files/ppp.sh

index d7dcc65f834047ed351f08933e0c5d690f8a7592..e0724fffa796a3b512f06beb62bbc5c1f303a978 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.4
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
index 53cfb1be1aeb1a29988e502c6f1ded43364b4d93..46a66c969cfb34f952414ed62bfecee951b631d6 100644 (file)
@@ -92,11 +92,11 @@ start_pppd() {
        }
 
        local demand
-       config_get_bool demand "$cfg" demand 0
+       config_get demand "$cfg" demand 0
 
        local demandargs
-       [ "$demand" -eq 1 ] && {
-               demandargs="precompiled-active-filter /etc/ppp/filter demand idle"
+       [ "$demand" -gt 0 ] && {
+               demandargs="precompiled-active-filter /etc/ppp/filter demand idle $demand"
                [ "$has_dns" -eq 0 ] && add_dns "$cfg" 1.1.1.1
        } || {
                demandargs="persist"