[package] update btrfs-progs to 0.19, patch by Benjamin Cama
authorFlorian Fainelli <florian@openwrt.org>
Sat, 20 Mar 2010 10:29:31 +0000 (10:29 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 20 Mar 2010 10:29:31 +0000 (10:29 +0000)
SVN-Revision: 20313

utils/btrfs-progs/Makefile
utils/btrfs-progs/files/btrfs-scan.init [new file with mode: 0644]
utils/btrfs-progs/patches/001-Makefile-gcc-fix

index 376eac7529a6f014eb7ad83da1dc5cad9bc64ad6..0c21f58230feece6e94ae7d71ae699a1270c353f 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=btrfs-progs
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=btrfs-progs
-PKG_VERSION:=0.18
+PKG_VERSION:=0.19
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.kernel.org/pub/linux/kernel/people/mason/btrfs/
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.kernel.org/pub/linux/kernel/people/mason/btrfs/
-PKG_MD5SUM:=1dfe59152a558eb2f79a4c398de6c4ef
+PKG_MD5SUM:=69e29ecd922e3f9dcb74a3a8f80b4f68
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -32,8 +32,7 @@ define Package/btrfs-progs/description
  GPL and open for contribution from anyone. 
 endef
 
  GPL and open for contribution from anyone. 
 endef
 
-progs = btrfsctl btrfsck mkfs.btrfs btrfs-debug-tree btrfs-show btrfs-vol \
-       btrfstune btrfs-image
+progs = btrfsctl mkfs.btrfs btrfs-debug-tree btrfs-show btrfs-vol btrfsck
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -48,6 +47,8 @@ endef
 define Package/btrfs-progs/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(addprefix $(PKG_INSTALL_DIR)/usr/bin/, $(progs)) $(1)/usr/bin/
 define Package/btrfs-progs/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(addprefix $(PKG_INSTALL_DIR)/usr/bin/, $(progs)) $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/btrfs-scan.init $(1)/etc/init.d/btrfs-scan
 endef
 
 $(eval $(call BuildPackage,btrfs-progs))
 endef
 
 $(eval $(call BuildPackage,btrfs-progs))
diff --git a/utils/btrfs-progs/files/btrfs-scan.init b/utils/btrfs-progs/files/btrfs-scan.init
new file mode 100644 (file)
index 0000000..f1264ee
--- /dev/null
@@ -0,0 +1,9 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2009 OpenWrt.org
+
+START=19
+
+start() {
+       grep -q btrfs /proc/modules && /usr/bin/btrfsctl -a
+}
+
index 5d7f7e126eb49693019ed151fbba9ab53cfa7b31..37da622e551c72719ae348f3f440f07cee36ee44 100644 (file)
@@ -1,5 +1,5 @@
 diff --git a/Makefile b/Makefile
 diff --git a/Makefile b/Makefile
-index 3349079..cf5392f 100644
+index 8097b5a..63a734b 100644
 --- a/Makefile
 +++ b/Makefile
 @@ -36,37 +36,37 @@ version:
 --- a/Makefile
 +++ b/Makefile
 @@ -36,37 +36,37 @@ version:
@@ -17,9 +17,9 @@ index 3349079..cf5392f 100644
 -      gcc $(CFLAGS) -o btrfs-show btrfs-show.o $(objects) $(LDFLAGS) $(LIBS)
 +      $(CC) $(CFLAGS) -o btrfs-show btrfs-show.o $(objects) $(LDFLAGS) $(LIBS)
  
 -      gcc $(CFLAGS) -o btrfs-show btrfs-show.o $(objects) $(LDFLAGS) $(LIBS)
 +      $(CC) $(CFLAGS) -o btrfs-show btrfs-show.o $(objects) $(LDFLAGS) $(LIBS)
  
- btrfsck: $(objects) btrfsck.o bit-radix.o
--      gcc $(CFLAGS) -o btrfsck btrfsck.o $(objects) bit-radix.o $(LDFLAGS) $(LIBS)
-+      $(CC) $(CFLAGS) -o btrfsck btrfsck.o $(objects) bit-radix.o $(LDFLAGS) $(LIBS)
+ btrfsck: $(objects) btrfsck.o
+-      gcc $(CFLAGS) -o btrfsck btrfsck.o $(objects) $(LDFLAGS) $(LIBS)
++      $(CC) $(CFLAGS) -o btrfsck btrfsck.o $(objects) $(LDFLAGS) $(LIBS)
  
  mkfs.btrfs: $(objects) mkfs.o
 -      gcc $(CFLAGS) -o mkfs.btrfs $(objects) mkfs.o $(LDFLAGS) $(LIBS)
  
  mkfs.btrfs: $(objects) mkfs.o
 -      gcc $(CFLAGS) -o mkfs.btrfs $(objects) mkfs.o $(LDFLAGS) $(LIBS)
@@ -49,5 +49,5 @@ index 3349079..cf5392f 100644
 -      gcc $(CFLAGS) -o btrfs-convert $(objects) convert.o -lext2fs $(LDFLAGS) $(LIBS)
 +      $(CC) $(CFLAGS) -o btrfs-convert $(objects) convert.o -lext2fs $(LDFLAGS) $(LIBS)
  
 -      gcc $(CFLAGS) -o btrfs-convert $(objects) convert.o -lext2fs $(LDFLAGS) $(LIBS)
 +      $(CC) $(CFLAGS) -o btrfs-convert $(objects) convert.o -lext2fs $(LDFLAGS) $(LIBS)
  
clean :
-       rm -f $(progs) cscope.out *.o .*.d btrfs-convert
manpages:
+       cd man; make