uhttpd: add a config option for using ustream-polarssl, and use it by default
authorFelix Fietkau <nbd@openwrt.org>
Sun, 29 Sep 2013 11:26:09 +0000 (11:26 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 29 Sep 2013 11:26:09 +0000 (11:26 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 38250

package/network/services/uhttpd/Makefile

index 7c3ea5b055acce18692f48af54969e61c8ca9388..2ff2ff798c834a015268edbabc481fb6a6075735 100644 (file)
@@ -51,7 +51,10 @@ endef
 define Package/uhttpd-mod-tls
   $(Package/uhttpd/default)
   TITLE+= (TLS plugin)
-  DEPENDS:=uhttpd +PACKAGE_uhttpd-mod-tls_cyassl:libustream-cyassl +PACKAGE_uhttpd-mod-tls_openssl:libustream-openssl
+  DEPENDS:=uhttpd \
+       +PACKAGE_uhttpd-mod-tls_polarssl:libustream-polarssl \
+       +PACKAGE_uhttpd-mod-tls_cyassl:libustream-cyassl \
+       +PACKAGE_uhttpd-mod-tls_openssl:libustream-openssl
 endef
 
 define Package/uhttpd-mod-tls/description
@@ -62,7 +65,10 @@ define Package/uhttpd-mod-tls/config
   choice
     depends on PACKAGE_uhttpd-mod-tls
     prompt "TLS Provider"
-    default PACKAGE_uhttpd-mod-tls_cyassl
+    default PACKAGE_uhttpd-mod-tls_polarssl
+
+    config PACKAGE_uhttpd-mod-tls_polarssl
+      bool "PolarSSL"
 
     config PACKAGE_uhttpd-mod-tls_cyassl
       bool "CyaSSL"