[packages] httping: update to 1.4.3
authorStephen Walker <stephendwalker@gmail.com>
Tue, 13 Jul 2010 09:08:45 +0000 (09:08 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Tue, 13 Jul 2010 09:08:45 +0000 (09:08 +0000)
SVN-Revision: 22163

net/httping/Makefile
net/httping/patches/002-version.patch

index e854627f3690285a07980de9a183f198483eb573..0622fdcd42b0fde884e546a905bcb7c9fdaf5459 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=httping
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=httping
-PKG_VERSION:=1.4.1
+PKG_VERSION:=1.4.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
-PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
-PKG_MD5SUM:=bde1ff3c01343d2371d8f34fbf8a1d9a
+PKG_SOURCE_URL:=http://www.vanheusden.com/httping
+PKG_MD5SUM:=a3830a3e8fbfb702bb7510ac4f99d795
 
 PKG_INSTALL:=1
 
 
 PKG_INSTALL:=1
 
index 6974904b7d3184c61677ef62de98e7e4c8e99e47..7848c96d57b7440fc25ce3b18f6f3abec84189e0 100644 (file)
@@ -1,15 +1,15 @@
 --- a/main.c
 +++ b/main.c
 --- a/main.c
 +++ b/main.c
-@@ -40,6 +40,8 @@
+@@ -41,6 +41,8 @@
  #include "utils.h"
  #include "error.h"
  
  #include "utils.h"
  #include "error.h"
  
-+#define VERSION "1.4.1"
++#define VERSION "1.4.3"
 +
  static volatile int stop = 0;
  
  int quiet = 0;
 +
  static volatile int stop = 0;
  
  int quiet = 0;
-@@ -51,7 +53,7 @@ char last_error[ERROR_BUFFER_SIZE];
+@@ -52,7 +54,7 @@ char last_error[ERROR_BUFFER_SIZE];
  
  void version(void)
  {
  
  void version(void)
  {
@@ -18,7 +18,7 @@
  #ifndef NO_SSL
        fprintf(stderr, "SSL support included\n");
  #endif
  #ifndef NO_SSL
        fprintf(stderr, "SSL support included\n");
  #endif
-@@ -525,7 +527,7 @@ int main(int argc, char *argv[])
+@@ -606,7 +608,7 @@ int main(int argc, char *argv[])
        if (useragent)
                sprintf(&request[strlen(request)], "User-Agent: %s\r\n", useragent);
        else
        if (useragent)
                sprintf(&request[strlen(request)], "User-Agent: %s\r\n", useragent);
        else