[package] package blkid out of e2fsprogs (#4720)
authorFlorian Fainelli <florian@openwrt.org>
Fri, 6 Mar 2009 04:00:22 +0000 (04:00 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 6 Mar 2009 04:00:22 +0000 (04:00 +0000)
SVN-Revision: 14756

package/e2fsprogs/Makefile

index b8bf345a917d9eb40270b63e72a311223d61ffb4..d284a82b9b46a150bc2f3f7ff2975744e3de4361 100644 (file)
@@ -101,6 +101,12 @@ $(call Package/e2fsprogs)
   DEPENDS:=e2fsprogs
 endef
 
+define Package/blkid
+$(call Package/e2fsprogs)
+  TITLE:=Command-line utility to locate/print block device attributes
+  DEPENDS:=e2fsprogs
+endef
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
@@ -186,6 +192,11 @@ define Package/badblocks/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/badblocks $(1)/usr/sbin/
 endef
 
+define Package/blkid/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/blkid $(1)/usr/sbin/
+endef
+
 $(eval $(call BuildPackage,e2fsprogs))
 $(eval $(call BuildPackage,libuuid))
 $(eval $(call BuildPackage,uuidgen))
@@ -194,3 +205,4 @@ $(eval $(call BuildPackage,libext2fs))
 $(eval $(call BuildPackage,tune2fs))
 $(eval $(call BuildPackage,resize2fs))
 $(eval $(call BuildPackage,badblocks))
+$(eval $(call BuildPackage,blkid))