projects
/
openwrt
/
svn-archive
/
archive.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
|
inline
| side by side (parent:
16bd794
)
Update dbus package to version 1.2.3
author
Lars-Peter Clausen
<lars@metafoo.de>
Thu, 25 Sep 2008 13:27:14 +0000
(13:27 +0000)
committer
Lars-Peter Clausen
<lars@metafoo.de>
Thu, 25 Sep 2008 13:27:14 +0000
(13:27 +0000)
SVN-Revision: 12699
utils/dbus/Makefile
patch
|
blob
|
history
diff --git
a/utils/dbus/Makefile
b/utils/dbus/Makefile
index 094b720df497a18bc736bbeba5094a6d67ff8e6c..24f0997e8ef2b4db9c3955c96d9b7efcc63d4d48 100644
(file)
--- a/
utils/dbus/Makefile
+++ b/
utils/dbus/Makefile
@@
-9,21
+9,24
@@
include $(TOPDIR)/rules.mk
PKG_NAME:=dbus
include $(TOPDIR)/rules.mk
PKG_NAME:=dbus
-PKG_VERSION:=1.
0
.3
-PKG_RELEASE:=
1
+PKG_VERSION:=1.
2
.3
+PKG_RELEASE:=
2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://dbus.freedesktop.org/releases/dbus/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://dbus.freedesktop.org/releases/dbus/
-PKG_MD5SUM:=
ce328423db5743fe9006d39113b5324d
+PKG_MD5SUM:=
f71641385768e99361bd298568207cee
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/package.mk
+PKG_INSTALL=1
+
+TARGET_LDFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
define Package/dbus/Default
define Package/dbus/Default
- SECTION:=utils
- CATEGORY:=Utilities
- TITLE:=Simple interprocess messaging system
- URL:=http://dbus.freedesktop.org/
+
SECTION:=utils
+
CATEGORY:=Utilities
+
TITLE:=Simple interprocess messaging system
+
URL:=http://dbus.freedesktop.org/
endef
define Package/dbus/Default/description
endef
define Package/dbus/Default/description
@@
-84,23
+87,21
@@
CONFIGURE_VARS+= \
ac_cv_have_abstract_sockets="yes" \
ac_cv_have_abstract_sockets="yes" \
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
-endef
-
define Build/InstallDev
define Build/InstallDev
- mkdir -p $(1)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/dbus-1.0 \
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/include/dbus-1.0 \
$(1)/usr/include/
$(1)/usr/include/
- mkdir -p $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdbus-1.{a,so*} \
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(INSTALL_DATA) \
+ $(PKG_INSTALL_DIR)/usr/lib/libdbus-1.{a,so*} \
$(1)/usr/lib/
$(1)/usr/lib/
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/dbus-1.0 \
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/dbus-1.0 \
$(1)/usr/lib/
$(1)/usr/lib/
- mkdir -p $(1)/usr/lib/pkgconfig
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/dbus-1.pc \
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(INSTALL_DATA) \
+ $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/dbus-1.pc \
$(1)/usr/lib/pkgconfig/
endef
$(1)/usr/lib/pkgconfig/
endef