package/base-files-network: fix udhcpc issues introduced in r28866 (closes: #10383)
authorNicolas Thill <nico@openwrt.org>
Fri, 11 Nov 2011 13:23:29 +0000 (13:23 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 11 Nov 2011 13:23:29 +0000 (13:23 +0000)
SVN-Revision: 28942

package/base-files-network/Makefile
package/base-files-network/files/lib/network/config.sh

index ead94580986910a2c4f7dbe990d6ce808faa2eab..65ed020ac9171bd745fcfd547c3be7132c7db035 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files-network
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_BUILD_DEPENDS:=opkg/host
 
index da45089dffcfb7a69532721d738f0693a642954a..feeaa2f9ce3099c22ed503255df83e677c343fa4 100755 (executable)
@@ -370,7 +370,7 @@ setup_interface() {
                        local pidfile="/var/run/dhcp-${iface}.pid"
 
                        SERVICE_PID_FILE="$pidfile" \
-                       service_stop udhcpc
+                       service_stop /sbin/udhcpc
 
                        local ipaddr netmask hostname proto1 clientid vendorid broadcast reqopts
                        config_get ipaddr "$config" ipaddr
@@ -386,15 +386,21 @@ setup_interface() {
                                $DEBUG ifconfig "$iface" "$ipaddr" ${netmask:+netmask "$netmask"}
 
                        # additional request options
-                       local opt dhcpopts
+                       local opt dhcpopts daemonize
                        for opt in $reqopts; do
                                append dhcpopts "-O $opt"
                        done
 
                        # don't stay running in background if dhcp is not the main proto on the interface (e.g. when using pptp)
-                       [ "$proto1" != "$proto" ] && append dhcpopts "-n -q" || append dhcpopts "-O rootpath -R &"
+                       [ "$proto1" != "$proto" ] && {
+                               append dhcpopts "-n -q"
+                       } || {
+                               append dhcpopts "-O rootpath -R"
+                               daemonize=1
+                       }
                        [ "$broadcast" = 1 ] && broadcast="-O broadcast" || broadcast=
 
+                       SERVICE_DAEMONIZE=$daemonize \
                        SERVICE_PID_FILE="$pidfile" \
                        service_start /sbin/udhcpc -t 0 -i "$iface" \
                                ${ipaddr:+-r $ipaddr} \