[packages] collectd: currently the build fails due to the combination of -Werror...
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 9 Dec 2011 18:02:03 +0000 (18:02 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 9 Dec 2011 18:02:03 +0000 (18:02 +0000)
SVN-Revision: 29489

utils/collectd/patches/003-remove-werror.patch [new file with mode: 0644]
utils/collectd/patches/900-add-iwinfo-plugin.patch

diff --git a/utils/collectd/patches/003-remove-werror.patch b/utils/collectd/patches/003-remove-werror.patch
new file mode 100644 (file)
index 0000000..89fce67
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -7,7 +7,7 @@ SUBDIRS += liboconfig
+ endif
+ if COMPILER_IS_GCC
+-AM_CFLAGS = -Wall -Werror
++AM_CFLAGS = -Wall
+ endif
+ AM_CPPFLAGS = -DPREFIX='"${prefix}"'
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -1836,7 +1836,7 @@ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ SUBDIRS = libcollectdclient $(am__append_1) $(am__append_2)
+-@COMPILER_IS_GCC_TRUE@AM_CFLAGS = -Wall -Werror
++@COMPILER_IS_GCC_TRUE@AM_CFLAGS = -Wall
+ AM_CPPFLAGS = -DPREFIX='"${prefix}"' \
+       -DCONFIGFILE='"${sysconfdir}/${PACKAGE_NAME}.conf"' \
+       -DLOCALSTATEDIR='"${localstatedir}"' \
index 09fca509ad0b5217bc1dd60c9af48cae5e015394..f195c1b18de5484195b143c13fe8b4bb311e9410 100644 (file)
 +                      continue;
 +
 +              if (strstr(ifname, "mon.") || strstr(ifname, ".sta") ||
-+                  strstr(ifname, "wmaster") || strstr(ifname, "wifi"))
++                  strstr(ifname, "tmp.") || strstr(ifname, "wifi"))
 +                      continue;
 +
 +              iwinfo_process(ifname);