[package] firewall: also establish forward rules when setting up nat reflection,...
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 3 Oct 2010 18:11:59 +0000 (18:11 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 3 Oct 2010 18:11:59 +0000 (18:11 +0000)
SVN-Revision: 23201

package/firewall/Makefile
package/firewall/files/reflection.hotplug

index 1f461567b3423e7fb606c0939dc73ca83f22bdaa..59edb0e3f3ae70665123984e5b57cbe522a7270f 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=2
 PKG_NAME:=firewall
 
 PKG_VERSION:=2
-PKG_RELEASE:=18
+PKG_RELEASE:=19
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
index b3b5e5ecce29336b6931583d0a98d34cb3ed34c1..33d121cec41e8b6fc8284b6d980e279d53257cb3 100644 (file)
@@ -15,6 +15,11 @@ if [ "$ACTION" = "add" ] && [ "$INTERFACE" = "wan" ]; then
                iptables -t nat -A postrouting_rule -j nat_reflection_out
        }
 
                iptables -t nat -A postrouting_rule -j nat_reflection_out
        }
 
+       iptables -t filter -F nat_reflection_fwd 2>/dev/null || {
+               iptables -t filter -N nat_reflection_fwd
+               iptables -t filter -A forwarding_rule -j nat_reflection_fwd
+       }
+
        find_networks() {
                find_networks_cb() {
                        local cfg="$1"
        find_networks() {
                find_networks_cb() {
                        local cfg="$1"
@@ -34,10 +39,14 @@ if [ "$ACTION" = "add" ] && [ "$INTERFACE" = "wan" ]; then
 
                config_foreach find_networks_cb zone "$1"
        }
 
                config_foreach find_networks_cb zone "$1"
        }
-       
+
        setup_fwd() {
                local cfg="$1"
 
        setup_fwd() {
                local cfg="$1"
 
+               local reflection
+               config_get_bool reflection "$cfg" reflection 1
+               [ "$reflection" == 1 ] || return
+
                local src
                config_get src "$cfg" src
 
                local src
                config_get src "$cfg" src
 
@@ -56,10 +65,6 @@ if [ "$ACTION" = "add" ] && [ "$INTERFACE" = "wan" ]; then
                                local proto
                                config_get proto "$cfg" proto
 
                                local proto
                                config_get proto "$cfg" proto
 
-                               local reflection
-                               config_get_bool reflection "$cfg" reflection 1
-                               [ "$reflection" == 1 ] || return
-
                                local epmin epmax extport
                                config_get extport "$cfg" src_dport
                                [ -n "$extport" ] || return
                                local epmin epmax extport
                                config_get extport "$cfg" src_dport
                                [ -n "$extport" ] || return
@@ -98,6 +103,11 @@ if [ "$ACTION" = "add" ] && [ "$INTERFACE" = "wan" ]; then
                                                                -s $lanip/$lanmk -d $inthost \
                                                                -p $p --dport $ipmin${ipmax:+:$ipmax} \
                                                                -j SNAT --to-source $lanip
                                                                -s $lanip/$lanmk -d $inthost \
                                                                -p $p --dport $ipmin${ipmax:+:$ipmax} \
                                                                -j SNAT --to-source $lanip
+
+                                                       iptables -t filter -A nat_reflection_fwd \
+                                                               -s $lanip/$lanmk -d $inthost \
+                                                               -p $p --dport $ipmin${ipmax:+:$ipmax} \
+                                                               -j ACCEPT
                                                ;;
                                        esac
                                done
                                                ;;
                                        esac
                                done
@@ -108,4 +118,3 @@ if [ "$ACTION" = "add" ] && [ "$INTERFACE" = "wan" ]; then
        config_load firewall
        config_foreach setup_fwd redirect
 fi
        config_load firewall
        config_foreach setup_fwd redirect
 fi
-