name sercomm-based ar7 images (dg834/compatible) .img instead of .bin, because the...
authorFelix Fietkau <nbd@openwrt.org>
Sun, 12 Feb 2006 18:47:22 +0000 (18:47 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 12 Feb 2006 18:47:22 +0000 (18:47 +0000)
SVN-Revision: 3228

openwrt/target/linux/image/ar7/Makefile

index 3a803cbd8bb7c65e49ea53ab0ade3799264da7e2..2cdf18d66fc4e900cd7f7d203e9f1c59a670b8af 100644 (file)
@@ -84,13 +84,13 @@ install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS)-$(1).bin
 endef
 
 define sercomm_template
 endef
 
 define sercomm_template
-$(BIN_DIR)/openwrt-$(1)-$(KERNEL)-$(FS).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).bin
+$(BIN_DIR)/openwrt-$(1)-$(KERNEL)-$(FS).img: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).bin
        cat sercomm/adam2.bin "$$^" > "$$@.tmp"
        dd if=sercomm/$(1) of="$$@.tmp" bs=$$$$((0x3e0000 - 80)) seek=1 conv=notrunc
        $(STAGING_DIR)/bin/dgfirmware -f -w "$$@" "$$@.tmp"
        rm -f "$$@.tmp"
 
        cat sercomm/adam2.bin "$$^" > "$$@.tmp"
        dd if=sercomm/$(1) of="$$@.tmp" bs=$$$$((0x3e0000 - 80)) seek=1 conv=notrunc
        $(STAGING_DIR)/bin/dgfirmware -f -w "$$@" "$$@.tmp"
        rm -f "$$@.tmp"
 
-install: $(BIN_DIR)/openwrt-$(1)-$(KERNEL)-$(FS).bin
+install: $(BIN_DIR)/openwrt-$(1)-$(KERNEL)-$(FS).img
 endef
 
 $(eval $(call sercomm_template,dg834))
 endef
 
 $(eval $(call sercomm_template,dg834))