[packages] Require* calls must now be placed before BuildPackage calls
authorAndy Boyett <agb@openwrt.org>
Thu, 14 May 2009 07:13:06 +0000 (07:13 +0000)
committerAndy Boyett <agb@openwrt.org>
Thu, 14 May 2009 07:13:06 +0000 (07:13 +0000)
SVN-Revision: 15835

14 files changed:
Xorg/lib/gtk2/Makefile
Xorg/lib/vte/Makefile
Xorg/xorg/font/font-misc-misc/Makefile
lang/numpy/Makefile
lang/perl/Makefile
lang/ruby/Makefile
lang/sablevm-sdk/Makefile
lang/telepathy-python/Makefile
libs/avahi/Makefile
libs/popt/Makefile
net/nrpe/Makefile
net/squid/Makefile
utils/firmwarehotplug/Makefile
utils/lilo/Makefile

index 598dfbd3312c90289fd06bf65d0c266c44db4d85..17dd79ed5ab84e80a73f23b059ccde32a5d46b11 100644 (file)
@@ -121,8 +121,10 @@ define Package/gtk2-cups/install
                $(1)/usr/lib/gtk-2.0/2.10.0/printbackends/
 endef
 
-$(eval $(call BuildPackage,gtk2))
-$(eval $(call BuildPackage,gtk2-cups))
 $(eval $(call RequireCommand,gdk-pixbuf-csource, \
        Please install gtk2.0-dev \
 ))
+
+$(eval $(call BuildPackage,gtk2))
+$(eval $(call BuildPackage,gtk2-cups))
+
index 143b15798a4a4da80cf138ec8649e4e2597702b3..7d6d4803938aba0fc49c60891e24f3cd6d23ce49 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -103,9 +103,10 @@ define Package/python-vte/install
                $(1)$(PYTHON_PKG_DIR)/gtk-2.0
 endef
 
-$(eval $(call BuildPackage,vte))
-$(eval $(call BuildPackage,python-vte))
-
 $(eval $(call RequireCommand,intltool-update, \
     $(PKG_NAME) requires intltool >= 0.35.0 \
 ))
+
+$(eval $(call BuildPackage,vte))
+$(eval $(call BuildPackage,python-vte))
+
index cb541c723dca75126b1b5af09e3b2e6a900af4c7..108c5456877655951f61d129b018faf595cfd1e1 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -26,14 +26,14 @@ endef
 define Package/font-base
   $(call Package/font-misc-misc/Default)
   DEPENDS:=+xserver +font-util @DISPLAY_SUPPORT
-  TITLE:=font-base 
+  TITLE:=font-base
   URL:=http://xorg.freedesktop.org/
 endef
 
 define Package/font-misc-misc
   $(call Package/font-misc-misc/Default)
   DEPENDS:=font-base
-  TITLE:=font-misc-misc 
+  TITLE:=font-misc-misc
   URL:=http://xorg.freedesktop.org/
 endef
 
@@ -44,7 +44,7 @@ define Build/Compile
        UTIL_DIR="$(STAGING_DIR)/usr/lib/X11/fonts/util/" make -e -C $(PKG_BUILD_DIR)
        DESTDIR=$(PKG_INSTALL_DIR) $(MAKE) -C $(PKG_BUILD_DIR) $(MAKE_FLAGS) install
        find $(PKG_INSTALL_DIR) -name fonts.dir | \
-               xargs rm  
+               xargs rm
 endef
 
 define Build/Configure
@@ -120,9 +120,6 @@ if [ ! -z $${FILE_NEW} ]; then
 fi
 endef
 
-$(eval $(call BuildPackage,font-misc-misc))
-$(eval $(call BuildPackage,font-base))
-
 # FIXME: replace with native versions
 $(eval $(call RequireCommand,mkfontscale, \
        Please install mkfontscale (usually in xfonts-utils) \
@@ -131,3 +128,7 @@ $(eval $(call RequireCommand,mkfontdir, \
        Please install mkfontdir (usually in xfonts-utils) \
 ))
 
+$(eval $(call BuildPackage,font-misc-misc))
+$(eval $(call BuildPackage,font-base))
+
+
index 03fa91c003e675c482cc486d5ed6af28001c0165..a99b5f5fb784da00ff55bafe849eb2751a684260 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -39,8 +39,6 @@ define Package/numpy/install
        cp -r $(PKG_INSTALL_DIR)/* $(1)
 endef
 
-$(eval $(call BuildPackage,numpy))
-
 define Require/python25-dev
 [ -e /usr/include/python2.5/pyconfig.h ]
 endef
@@ -48,3 +46,6 @@ endef
 $(eval $(call Require,python25-dev, \
        Please install Python 2.5 (including development headers and libraries) \
 ))
+
+$(eval $(call BuildPackage,numpy))
+
index 57104f9cd398c50becb68277941c6ad34d467ebb..e3cedd2af74acbda97e8be8eadd52ba53b8ca03a 100644 (file)
@@ -184,11 +184,11 @@ endef
 define Build/Compile
 endef
 
-$(eval $(call BuildPackage,microperl))
-$(eval $(call BuildPackage,perl))
-
 $(eval $(call RequireCommand,rsync, \
        $(PKG_NAME) requires rsync installed on the host-system. \
 ))
 
+$(eval $(call BuildPackage,microperl))
+$(eval $(call BuildPackage,perl))
+
 -include perlbase.mk
index c2620711be17d0e4b2216e04a871ad8aab288069..1f0ff0ce8b8cc01a70219880f205eee08ba9dceb 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -268,8 +268,8 @@ define Package/ruby-core/install
                \
                $(1)/usr/lib/ruby/1.8/yaml \
                $(1)/usr/lib/ruby/1.8/yaml.rb \
-               $(1)/usr/lib/ruby/1.8/*/syck.so \
-               
+               $(1)/usr/lib/ruby/1.8/*/syck.so
+
        find $(1) -name '*.h' | xargs rm -f
 endef
 
@@ -411,6 +411,10 @@ define Package/ruby-zlib/install
        ) | ( cd $(1); $(TAR) -xf - )
 endef
 
+$(eval $(call RequireCommand,ruby, \
+        $(PKG_NAME) requires ruby installed on the host-system. \
+))
+
 $(eval $(call BuildPackage,ruby))
 $(eval $(call BuildPackage,libruby))
 $(eval $(call BuildPackage,ruby-core))
@@ -434,7 +438,3 @@ $(eval $(call BuildPackage,ruby-xsd))
 $(eval $(call BuildPackage,ruby-yaml))
 $(eval $(call BuildPackage,ruby-zlib))
 
-$(eval $(call RequireCommand,ruby, \
-        $(PKG_NAME) requires ruby installed on the host-system. \
-))
-
index 4608feb2a89f7c9d279f2134fb269a74b19f871b..94174b11c00f566a615d33a8a10ab1d00a350fde 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006,2007 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -84,7 +84,7 @@ define Build/Configure
        )
 endef
 
-define Build/Compile   
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                EARLY_CONFIGURE= \
                EXTRA_CONFIGURE= \
@@ -126,12 +126,12 @@ define Package/sablevm-mini/install
                $(1)/usr/share/sablevm/examples/
 endef
 
-$(eval $(call BuildPackage,sablevm))
-$(eval $(call BuildPackage,sablevm-mini))
-
 $(foreach command, jikes fastjar, \
   $(eval $(call RequireCommand,$(command), \
    $(PKG_NAME) requires $(command). \
   )) \
 )
 
+$(eval $(call BuildPackage,sablevm))
+$(eval $(call BuildPackage,sablevm-mini))
+
index d47612d2f3e488e2015a7d30c0ae89811f48aa48..6a7a1745caf873d2d4bbba7bc72a66bd104f7120 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -41,8 +41,9 @@ define Package/telepathy-python/install
            $(1)$(PYTHON_PKG_DIR)
 endef
 
-$(eval $(call BuildPackage,telepathy-python))
-
 $(eval $(call RequireCommand,xsltproc, \
        $(PKG_NAME) requires xsltproc installed on the host-system. \
 ))
+
+$(eval $(call BuildPackage,telepathy-python))
+
index 152a3d5970dca87541db6e2bfd6afea995f561e5..3e8301c78b2f325ff39ebba47cfc1eaf39464a8f 100644 (file)
@@ -1,6 +1,5 @@
 #
-
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -48,7 +47,7 @@ define Package/libavahi
 endef
 
 define Package/libavahi/description
-$(call Package/avahi/Default/description) 
+$(call Package/avahi/Default/description)
  .
  This package contains the mDNS/DNS-SD shared libraries, used by other programs.
 endef
@@ -198,12 +197,12 @@ define Package/avahi-dnsconfd/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/avahi-dnsconfd $(1)/usr/sbin/
 endef
 
+$(eval $(call RequireCommand,intltool-update, \
+       $(PKG_NAME) requires intltool >= 0.35.0 \
+))
+
 $(eval $(call BuildPackage,libavahi))
 $(eval $(call BuildPackage,avahi-autoipd))
 $(eval $(call BuildPackage,avahi-daemon))
 $(eval $(call BuildPackage,avahi-dnsconfd))
 
-$(eval $(call RequireCommand,intltool-update, \
-       $(PKG_NAME) requires intltool >= 0.35.0 \
-))
-
index 27ad2558436e29bfe733f366f781e1e1fb03f306..f4ae7879039e7c5aec1d28431bc6f80b2daf626c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -51,8 +51,9 @@ define Package/libpopt/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpopt.so.* $(1)/usr/lib/
 endef
 
-$(eval $(call BuildPackage,libpopt))
-
 $(eval $(call RequireCommand,xgettext, \
        $(PKG_NAME) requires the GNU gettext development package installed on the local system to build. \
 ))
+
+$(eval $(call BuildPackage,libpopt))
+
index bd7f5728b14d149a6bf4d28653940227bef6260b..910df750e717b88ca1ecea9d513f56f305e7f5cc 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -84,9 +84,9 @@ define Package/nrpe/install
        $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
 endef
 
-$(eval $(call BuildPackage,nrpe))
-
 $(eval $(call RequireCommand,openssl, \
        $(PKG_NAME) requires openssl installed on the host-system. \
 ))
 
+$(eval $(call BuildPackage,nrpe))
+
index ec4a395dccb330bf81aa1a2399ba844fd0db948d..29e3fd54e587ab2b9ecd123a484b11c72224b8f8 100644 (file)
@@ -127,8 +127,8 @@ CONFIGURE_ARGS += \
        --enable-digest-auth-helpers="password" \
        --enable-external-acl-helpers="ip_user unix_group" \
        --enable-epoll \
-       --with-maxfd=4096 \
-       
+       --with-maxfd=4096
+
 CONFIGURE_VARS += \
        ac_cv_header_linux_netfilter_ipv4_h=yes \
 
@@ -168,6 +168,11 @@ define Package/squid-mod-cachemgr/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/cachemgr.cgi $(1)/www/cgi-bin/
 endef
 
+$(eval $(call RequireHeader,/usr/include/openssl/ssl.h, \
+       $(PKG_NAME) requires the openssl development (named like libssl-dev, \
+       depending of your package manager) package be installed on the host-system. \
+))
+
 $(eval $(call BuildPackage,squid))
 $(eval $(call BuildPackage,squid-mod-cachemgr))
 $(eval $(call BuildPlugin,squid-mod-basic-auth-getpwnam,getpwname_auth))
@@ -179,7 +184,3 @@ $(eval $(call BuildPlugin,squid-mod-external-acl-unix-group,squid_unix_group))
 $(eval $(call BuildPlugin,squid-mod-ntlm-auth-fakeauth,fakeauth_auth))
 $(eval $(call BuildPlugin,squid-mod-ntlm-auth-smb-auth,ntlm_auth))
 
-$(eval $(call RequireHeader,/usr/include/openssl/ssl.h, \
-       $(PKG_NAME) requires the openssl development (named like libssl-dev, \
-       depending of your package manager) package be installed on the host-system. \
-))
index cdf85e32814f76820d218e810a53c861184b0690..62bab09f03fec4cc71e12908b53be99b2ec402d7 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -48,8 +48,6 @@ define Package/firmwarehotplug/install
        install -m644 $(PKG_BUILD_DIR)/ezusb/midi/original/ezusbmidi2x2.ihx $(1)/usr/share/usb/ezusbmidi
 endef
 
-$(eval $(call BuildPackage,firmwarehotplug))
-
 define Require/working-sdcc
        sdcc -v 2>&1 | awk '($$$$1 == "SDCC") && ($$$$3 == "mcs51/gbz80/z80/avr/ds390/pic16/pic14/TININative/xa51/ds400/hc08") { print "ok" }' | grep ok > /dev/null
 endef
@@ -63,3 +61,6 @@ $(eval $(call Require,working-sdcc, \
        mcs51/gbz80/z80/avr/ds390/pic16/pic14/TININative/xa51/ds400/hc08. You might consider \
        installing the non-free version. \
 ))
+
+$(eval $(call BuildPackage,firmwarehotplug))
+
index c1bfe7e7e876ce531cb4817226a0ae625714f01d..44156ccc4fe59f8d8a27c8079608f226f20817b2 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -41,10 +41,11 @@ define Package/lilo/install
        $(CP) ./files/boot.msg $(1)/etc/
 endef
 
-$(eval $(call BuildPackage,lilo))
-
 $(foreach command, as86 ld86, \
   $(eval $(call RequireCommand,$(command), \
    $(PKG_NAME) requires $(command). \
   )) \
 )
+
+$(eval $(call BuildPackage,lilo))
+