enable optional building of u-boot for avr32
authorImre Kaloz <kaloz@openwrt.org>
Mon, 28 Apr 2008 14:10:09 +0000 (14:10 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Mon, 28 Apr 2008 14:10:09 +0000 (14:10 +0000)
SVN-Revision: 10961

target/linux/avr32/image/Config.in [new file with mode: 0644]
target/linux/avr32/image/Makefile
target/linux/avr32/image/u-boot/Makefile [new file with mode: 0644]

diff --git a/target/linux/avr32/image/Config.in b/target/linux/avr32/image/Config.in
new file mode 100644 (file)
index 0000000..3988468
--- /dev/null
@@ -0,0 +1,13 @@
+config AVR32_UBOOT
+       bool "Build u-boot loader"
+       depends TARGET_avr32
+       default n
+
+config AVR32_UBOOT_TARGET
+       string "U-Boot Board Configuration"
+       depends TARGET_avr32
+       depends AVR32_UBOOT
+       default "atngw100"
+       help
+         For all supported boards there are ready-to-use default
+               configurations available; just type "<board_name>".
index 35689841895070fa916f9ba991dddfe5709133a2..cbaf07dfb38577a0834566280dededef73296dba 100644 (file)
@@ -4,9 +4,18 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
+define Build/Clean
+       $(MAKE) -C u-boot clean
+endef
+
+define Build/Compile
+       $(MAKE) -C u-boot compile
+endef
+
 define Image/Prepare
        cp $(LINUX_DIR)/arch/avr32/boot/images/uImage $(KDIR)/uImage
 endef
diff --git a/target/linux/avr32/image/u-boot/Makefile b/target/linux/avr32/image/u-boot/Makefile
new file mode 100644 (file)
index 0000000..c6db50c
--- /dev/null
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=u-boot
+PKG_VERSION:=1.3.2
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
+PKG_MD5SUM:=78b1c2722d3907b5fae2cd219dbaf927
+PKG_CAT:=bzcat
+
+include $(INCLUDE_DIR)/package.mk
+
+UBOOT_CONFIG=$(strip $(subst ",, $(CONFIG_AVR32_UBOOT_TARGET)))
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIG)_config
+       export CROSS_COMPILE=$(TARGET_CROSS);
+       $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Build/InstallDev
+       dd if=$(PKG_BUILD_DIR)/u-boot.bin of=$(BIN_DIR)/u-boot-$(CONFIG_AVR32_UBOOT_TARGET).bin bs=64k count=1 conv=sync
+endef
+
+$(eval $(call Build/DefaultTargets))