[kernel] update to 2.6.30, refresh patches
authorFlorian Fainelli <florian@openwrt.org>
Fri, 4 Dec 2009 14:52:45 +0000 (14:52 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 4 Dec 2009 14:52:45 +0000 (14:52 +0000)
SVN-Revision: 18635

35 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/amazon/Makefile
target/linux/ar7/Makefile
target/linux/ar71xx/Makefile
target/linux/atheros/Makefile
target/linux/au1000/Makefile
target/linux/avr32/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/cobalt/Makefile
target/linux/cobalt/patches/001-no_module_reloc.patch
target/linux/ep93xx/Makefile
target/linux/etrax/Makefile
target/linux/gemini/Makefile
target/linux/generic-2.6/patches-2.6.30/015-arm_export___cpu_flush_dcache_page.patch
target/linux/goldfish/Makefile
target/linux/ifxmips/Makefile
target/linux/iop32x/Makefile
target/linux/kirkwood/Makefile
target/linux/mpc52xx/Makefile
target/linux/mpc83xx/Makefile
target/linux/octeon/Makefile
target/linux/olpc/Makefile
target/linux/orion/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ps3/Makefile
target/linux/pxcab/Makefile
target/linux/ramips/Makefile
target/linux/rb532/Makefile
target/linux/rdc/Makefile
target/linux/s3c24xx/Makefile
target/linux/sibyte/Makefile
target/linux/uml/Makefile

index 4562d5a3880dcdec19a69dea6643f9cc17a025c9..cb2fd60c5a471c7c4683ce196761a7bff0101844 100644 (file)
@@ -19,8 +19,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.28.10)
   LINUX_KERNEL_MD5SUM:=c4efb2c494d749cb5de274f8ae41c3fa
 endif
 ifeq ($(LINUX_VERSION),2.6.28.10)
   LINUX_KERNEL_MD5SUM:=c4efb2c494d749cb5de274f8ae41c3fa
 endif
-ifeq ($(LINUX_VERSION),2.6.30.9)
-  LINUX_KERNEL_MD5SUM:=5a4cd5543a9d7c1a819700b21be31ef1
+ifeq ($(LINUX_VERSION),2.6.30.10)
+  LINUX_KERNEL_MD5SUM:=eb6be465f914275967a5602cb33662f5
 endif
 ifeq ($(LINUX_VERSION),2.6.31.6)
   LINUX_KERNEL_MD5SUM:=485472df88af84becdcf47f45de3ba46
 endif
 ifeq ($(LINUX_VERSION),2.6.31.6)
   LINUX_KERNEL_MD5SUM:=485472df88af84becdcf47f45de3ba46
index d271416189fa8a15bbd73dbdb0aa00d97f1e6b76..bcafec0b77b436de9b5fdfa8a0dd285383787104 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 SUBTARGETS:=router_le router_be
 INITRAMFS_EXTRA_FILES:=
 
 SUBTARGETS:=router_le router_be
 INITRAMFS_EXTRA_FILES:=
 
index d0787ca25c29e2f8bb556cfdd7dca2fe8e9e701c..826937a5fed2bae912c3e6009e21fbfc94068726 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=amazon
 BOARDNAME:=Infineon Amazon
 FEATURES:=squashfs jffs2 broken
 BOARD:=amazon
 BOARDNAME:=Infineon Amazon
 FEATURES:=squashfs jffs2 broken
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 9704515a3c17e9e1900a884457aaf3234aeffbdb..e553bb2abb42b00565bfabf01baf23b7ba3f52c1 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 
 BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index c604acfabcf6b8d2d04d4f745525675d00f0fa66..b16b428636e0a9a5328107209b386d56e289d34f 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atheros AR71xx/AR7240/AR913x
 FEATURES:=squashfs jffs2 tgz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
 FEATURES:=squashfs jffs2 tgz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index edee9e671641168d1bbb0941f9f875630590b277..885a93aa4552ee98d7c0a8e5f641ac9fb63d2efd 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros AR231x/AR5312
 FEATURES:=squashfs jffs2
 
 BOARDNAME:=Atheros AR231x/AR5312
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index e752ed8536427bf0c890719eef66eda8b5fba488..d0bd1425a5cb33f05b834e565deedc5d294f96b0 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=RMI/AMD AU1x00
 FEATURES:=jffs2 usb pci
 SUBTARGETS=au1500 au1550
 
 FEATURES:=jffs2 usb pci
 SUBTARGETS=au1500 au1550
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += hostapd-mini yamonenv
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += hostapd-mini yamonenv
index 02dca1cc9a5fba4059a5d60233558bffb3e72394..0cffccb8e9fb1c3644df47cddf89a40e6b04c9d9 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=avr32
 BOARD:=avr32
 BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 BOARD:=avr32
 BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 421bddf246ca21ce918ee910bd784e9485d0f1e6..f1344956acb0f1f3752597015bb8466be5195a83 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb
 
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += hostapd-mini kmod-switch kmod-diag nvram
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += hostapd-mini kmod-switch kmod-diag nvram
index 4a3b43a4e61edc452ae9c62c29822d6937a6e647..dec4806d47c7c4eea4314d948e1a85cfe569263b 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 103da193aee259b6ef2245a18b1a58bd17e4871c..266e4dfdbf36c02b682783cc76ca71a06bdaeed5 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cobalt Microservers
 FEATURES:=tgz pci ext2
 CFLAGS:=-O2 -pipe -mtune=r5000 -funit-at-a-time
 
 FEATURES:=tgz pci ext2
 CFLAGS:=-O2 -pipe -mtune=r5000 -funit-at-a-time
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 833dea7919bfa57a551e877302e2d3c519e6fed4..b6604ea07aece69f794202964e903e18acfa40d8 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN linux-2.6.30.7/arch/mips/Makefile linux-2.6.30.7.new/arch/mips/Makefile
---- linux-2.6.30.7/arch/mips/Makefile  2009-09-27 13:17:16.000000000 +0200
-+++ linux-2.6.30.7.new/arch/mips/Makefile      2009-09-15 19:46:05.000000000 +0200
-@@ -83,7 +83,7 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -83,7 +83,7 @@ all-$(CONFIG_BOOT_ELF64)     := $(vmlinux-64
  cflags-y                      += -G 0 -mno-abicalls -fno-pic -pipe
  cflags-y                      += -msoft-float
  LDFLAGS_vmlinux                       += -G 0 -static -n -nostdlib
  cflags-y                      += -G 0 -mno-abicalls -fno-pic -pipe
  cflags-y                      += -msoft-float
  LDFLAGS_vmlinux                       += -G 0 -static -n -nostdlib
@@ -10,10 +9,9 @@ diff -urN linux-2.6.30.7/arch/mips/Makefile linux-2.6.30.7.new/arch/mips/Makefil
  
  cflags-y += -ffreestanding
  
  
  cflags-y += -ffreestanding
  
-diff -urN linux-2.6.30.7/arch/mips/include/asm/module.h linux-2.6.30.7.new/arch/mips/include/asm/module.h
---- linux-2.6.30.7/arch/mips/include/asm/module.h      2009-09-27 13:17:16.000000000 +0200
-+++ linux-2.6.30.7.new/arch/mips/include/asm/module.h  2009-09-15 19:46:05.000000000 +0200
-@@ -9,11 +9,6 @@
+--- a/arch/mips/include/asm/module.h
++++ b/arch/mips/include/asm/module.h
+@@ -9,11 +9,6 @@ struct mod_arch_specific {
        struct list_head dbe_list;
        const struct exception_table_entry *dbe_start;
        const struct exception_table_entry *dbe_end;
        struct list_head dbe_list;
        const struct exception_table_entry *dbe_start;
        const struct exception_table_entry *dbe_end;
@@ -25,10 +23,9 @@ diff -urN linux-2.6.30.7/arch/mips/include/asm/module.h linux-2.6.30.7.new/arch/
  };
  
  typedef uint8_t Elf64_Byte;           /* Type for a 8-bit quantity.  */
  };
  
  typedef uint8_t Elf64_Byte;           /* Type for a 8-bit quantity.  */
-diff -urN linux-2.6.30.7/arch/mips/kernel/module.c linux-2.6.30.7.new/arch/mips/kernel/module.c
---- linux-2.6.30.7/arch/mips/kernel/module.c   2009-09-27 13:17:16.000000000 +0200
-+++ linux-2.6.30.7.new/arch/mips/kernel/module.c       2009-09-15 19:46:05.000000000 +0200
-@@ -43,116 +43,6 @@
+--- a/arch/mips/kernel/module.c
++++ b/arch/mips/kernel/module.c
+@@ -43,116 +43,6 @@ static struct mips_hi16 *mips_hi16_list;
  static LIST_HEAD(dbe_list);
  static DEFINE_SPINLOCK(dbe_lock);
  
  static LIST_HEAD(dbe_list);
  static DEFINE_SPINLOCK(dbe_lock);
  
@@ -145,7 +142,7 @@ diff -urN linux-2.6.30.7/arch/mips/kernel/module.c linux-2.6.30.7.new/arch/mips/
  void *module_alloc(unsigned long size)
  {
  #ifdef MODULE_START
  void *module_alloc(unsigned long size)
  {
  #ifdef MODULE_START
-@@ -168,45 +58,16 @@
+@@ -168,45 +58,16 @@ void *module_alloc(unsigned long size)
  
        return __vmalloc_area(area, GFP_KERNEL, PAGE_KERNEL);
  #else
  
        return __vmalloc_area(area, GFP_KERNEL, PAGE_KERNEL);
  #else
@@ -193,7 +190,7 @@ diff -urN linux-2.6.30.7/arch/mips/kernel/module.c linux-2.6.30.7.new/arch/mips/
        /* FIXME: If module_region == mod->init_region, trim exception
             table entries. */
  }
        /* FIXME: If module_region == mod->init_region, trim exception
             table entries. */
  }
-@@ -214,24 +75,6 @@
+@@ -214,24 +75,6 @@ void module_free(struct module *mod, voi
  int module_frob_arch_sections(Elf_Ehdr *hdr, Elf_Shdr *sechdrs,
                              char *secstrings, struct module *mod)
  {
  int module_frob_arch_sections(Elf_Ehdr *hdr, Elf_Shdr *sechdrs,
                              char *secstrings, struct module *mod)
  {
@@ -218,7 +215,7 @@ diff -urN linux-2.6.30.7/arch/mips/kernel/module.c linux-2.6.30.7.new/arch/mips/
        return 0;
  }
  
        return 0;
  }
  
-@@ -254,41 +97,27 @@
+@@ -254,41 +97,27 @@ static int apply_r_mips_32_rela(struct m
        return 0;
  }
  
        return 0;
  }
  
@@ -274,7 +271,7 @@ diff -urN linux-2.6.30.7/arch/mips/kernel/module.c linux-2.6.30.7.new/arch/mips/
  {
        if (v % 4) {
                printk(KERN_ERR "module %s: dangerous relocation\n", me->name);
  {
        if (v % 4) {
                printk(KERN_ERR "module %s: dangerous relocation\n", me->name);
-@@ -296,31 +125,17 @@
+@@ -296,31 +125,17 @@ static int set_r_mips_26(struct module *
        }
  
        if ((v & 0xf0000000) != (((unsigned long)location + 4) & 0xf0000000)) {
        }
  
        if ((v & 0xf0000000) != (((unsigned long)location + 4) & 0xf0000000)) {
@@ -309,7 +306,7 @@ diff -urN linux-2.6.30.7/arch/mips/kernel/module.c linux-2.6.30.7.new/arch/mips/
  static int apply_r_mips_hi16_rel(struct module *me, u32 *location, Elf_Addr v)
  {
        struct mips_hi16 *n;
  static int apply_r_mips_hi16_rel(struct module *me, u32 *location, Elf_Addr v)
  {
        struct mips_hi16 *n;
-@@ -585,23 +400,11 @@
+@@ -585,23 +400,11 @@ int module_finalize(const Elf_Ehdr *hdr,
                list_add(&me->arch.dbe_list, &dbe_list);
                spin_unlock_irq(&dbe_lock);
        }
                list_add(&me->arch.dbe_list, &dbe_list);
                spin_unlock_irq(&dbe_lock);
        }
index 52cabaaaaaba001401050bafc47b19af6051a79f..dae98ad7cc25caae5ca4f9c7e4dae936ae62b3fa 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cirrus Logic EP93xx SoC
 FEATURES:=squashfs jffs2 ext2 tgz usb
 CFLAGS:=-Os -pipe -march=armv4t -funit-at-a-time
 
 FEATURES:=squashfs jffs2 ext2 tgz usb
 CFLAGS:=-Os -pipe -march=armv4t -funit-at-a-time
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 3dcfb2279f2a510fefa85dea1c652468f29a4c0e..df0d690431c6ff882c28d7acfcdfccb4225d4bd3 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=cris
 BOARD:=etrax
 BOARDNAME:=Foxboard (ETRAX 100LX)
 FEATURES:=squashfs jffs2
 BOARD:=etrax
 BOARDNAME:=Foxboard (ETRAX 100LX)
 FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
 DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
index 52a7c078bd3b08cc128af9c89f6b284ed7fad30d..d0e7bb9cc35f40a38f145bb0a2541d6f5c4046be 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cortina Systems CS351x
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
 
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 5b43c87a8cc73b5449a37c2305220da84e48d340..d778a1f7f6fe9c865cc048dc83fb90aa6244a99e 100644 (file)
@@ -16,8 +16,6 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
  arch/arm/mm/proc-syms.c |    1 +
  1 files changed, 1 insertions(+), 0 deletions(-)
 
  arch/arm/mm/proc-syms.c |    1 +
  1 files changed, 1 insertions(+), 0 deletions(-)
 
-diff --git a/arch/arm/mm/proc-syms.c b/arch/arm/mm/proc-syms.c
-index 195e48e..ac5c800 100644
 --- a/arch/arm/mm/proc-syms.c
 +++ b/arch/arm/mm/proc-syms.c
 @@ -27,6 +27,7 @@ EXPORT_SYMBOL(__cpuc_flush_kern_all);
 --- a/arch/arm/mm/proc-syms.c
 +++ b/arch/arm/mm/proc-syms.c
 @@ -27,6 +27,7 @@ EXPORT_SYMBOL(__cpuc_flush_kern_all);
@@ -28,6 +26,3 @@ index 195e48e..ac5c800 100644
  EXPORT_SYMBOL(dmac_inv_range);  /* because of flush_ioremap_region() */
  #else
  EXPORT_SYMBOL(cpu_cache);
  EXPORT_SYMBOL(dmac_inv_range);  /* because of flush_ioremap_region() */
  #else
  EXPORT_SYMBOL(cpu_cache);
--- 
-1.6.5.1
-
index 59a778c34660b5fed94a0b842d5ff2b6fcea7339..84342fded7a305d47217c959aaa2e0dd28c110ed 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Goldfish (Android Emulator)
 FEATURES:=
 CFLAGS:=-O2 -pipe -march=armv5te -mtune=xscale -funit-at-a-time
 
 FEATURES:=
 CFLAGS:=-O2 -pipe -march=armv5te -mtune=xscale -funit-at-a-time
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 DEVICE_TYPE=phone
 
 
 DEVICE_TYPE=phone
 
index 14ee8831f01f9f2d61bc9653049d11261509e3cf..addeef681096f7124698a2ba424d3273af844391 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ifxmips
 BOARDNAME:=Infineon Mips
 FEATURES:=squashfs jffs2 atm
 
 BOARDNAME:=Infineon Mips
 FEATURES:=squashfs jffs2 atm
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
index 6f3e78167d972759fb4389d494b6294685ab3c68..9bb89eee40703e523a4b81077b1121002b12e155 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=iop32x
 BOARDNAME:=Intel IOP32x
 FEATURES:=squashfs jffs2
 
 BOARDNAME:=Intel IOP32x
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index a82ca0e0b53d5582e3c534e0b50dec715a837158..a1e9e5f57fa63fb6b3f5d050602374b3e0664376 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=kirkwood
 BOARDNAME:=Marvell Kirkwood
 FEATURES:=tgz usb
 
 BOARDNAME:=Marvell Kirkwood
 FEATURES:=tgz usb
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 0e5e81db624a79498bda84563c5c7d9257ed1f28..35930bc2a9ceecf664e889ddc3cc8f3016b83bf6 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=mpc52xx
 BOARDNAME:=Freescale MPC52xx
 FEATURES:=tgz ext2
 
 BOARDNAME:=Freescale MPC52xx
 FEATURES:=tgz ext2
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
index 4dca6165eba8228b624dacdb35e030542af4ddd4..838955b91353e4ea8396c31158ce0bf38cb460fd 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=mpc83xx
 BOARDNAME:=Freescale MPC83xx
 FEATURES:=tgz broken
 
 BOARDNAME:=Freescale MPC83xx
 FEATURES:=tgz broken
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
index b5b2e35e913c89c5574f22a7b6e2c6b2882e03b6..ca4b9fc0dd5983974e0bbf7393d0b43c984b356c 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Octeon
 FEATURES:=squashfs jffs2 pci usb
 CFLAGS:=-Os -pipe -mtune=octeon -funit-at-a-time
 
 FEATURES:=squashfs jffs2 pci usb
 CFLAGS:=-Os -pipe -mtune=octeon -funit-at-a-time
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index fb535c976d18eeb016649407d112ea1b6dd43817..7c1d65ec96358591081669c14e1eb248d997a6a9 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=olpc
 BOARDNAME:=OLPC XO-1
 FEATURES:=squashfs ext2
 
 BOARDNAME:=OLPC XO-1
 FEATURES:=squashfs ext2
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci kmod-libertas
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci kmod-libertas
index 48fe61bdcc6926b7301af6bf9af19eb55e830aa8..f3a671ba7c8d69b02f467b0427a9e74ffa4f4ace 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Marvell Orion
 FEATURES:=squashfs
 SUBTARGETS=generic harddisk
 
 FEATURES:=squashfs
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 94c2a3bb8dcdfac46eedb777eca704530d74b227..7bfe0b0d24cbad5761b30373763fd7a537f7ddb1 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=AMCC/IBM PPC40x
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=405
 
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=405
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
index 6d9f593808830848957e9512c98dd64564197dd4..8f8f2c6b7e7661e7b98f9540883173948f8ee1f4 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
 
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
index 79f17fb0c7c3251ec31a05bebe24d28d4a17079e..e36e333cfe3bee9f90c33107d1baf0840b18b641 100644 (file)
@@ -13,7 +13,7 @@ MAINTAINER:=Geoff Levand <geoffrey.levand@am.sony.com>
 SUBTARGETS=petitboot
 FEATURES+=powerpc64
 
 SUBTARGETS=petitboot
 FEATURES+=powerpc64
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 KERNEL_CC:=
 
 
 KERNEL_CC:=
 
index 308c452e2f9ff386f24d02139d73f9db85be3bb1..7ca7c0536b477cf4e6e99c9a8229323ad735dff4 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=pxcab
 BOARDNAME:=PowerXCell Accelerator Board
 FEATURES+=powerpc64 fpu ramdisk
 
 BOARDNAME:=PowerXCell Accelerator Board
 FEATURES+=powerpc64 fpu ramdisk
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 KERNEL_CC:=
 
 
 KERNEL_CC:=
 
index f391a6a436afa105ed827706b08db4277a17d0fd..cf094f3963a506b6322ca9daafc5eb3d0035d58a 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 FEATURES:=squashfs broken
 
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 FEATURES:=squashfs broken
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=kmod-leds-gpio
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=kmod-leds-gpio
index 770a42804aa5807ef02c4abdb7663f649dde157c..e6233463a521887ce2562f3842f437f4e80e03ce 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci tgz
 
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci tgz
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += hostapd-mini kmod-madwifi kmod-input-rb532
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += hostapd-mini kmod-madwifi kmod-input-rb532
index 2d9d1fb834cd38564c4fbb82645f7e0fd23a207d..98146dcc16687d967c557e6f11c9766c1b48978b 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 pci usb pcmcia
 CFLAGS:=-Os -pipe -march=i486 -funit-at-a-time
 SUBTARGETS:=amit ar525w r8610 dir-450 sitecom
 
 CFLAGS:=-Os -pipe -march=i486 -funit-at-a-time
 SUBTARGETS:=amit ar525w r8610 dir-450 sitecom
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 67fab6ccc429af7da97d9a48dd00058e1e9f4daa..a0c186a86775799c712b561941e144c0886751dd 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Samsung S3C24xx
 FEATURES:=jffs2
 CFLAGS:=-O2 -pipe -march=armv4t -mtune=arm920t -funit-at-a-time
 
 FEATURES:=jffs2
 CFLAGS:=-O2 -pipe -march=armv4t -mtune=arm920t -funit-at-a-time
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 DEVICE_TYPE=phone
 
 
 DEVICE_TYPE=phone
 
index 097e416d0c95ce6ff7bb692a3fa0202600e0ed80..bfcd648cc05b25e17e7a9e15bc293d6ded5eb8ff 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Broadcom/SiByte SB-1
 FEATURES:=fpu
 CFLAGS:=-Os -pipe -march=sb1 -funit-at-a-time
 
 FEATURES:=fpu
 CFLAGS:=-Os -pipe -march=sb1 -funit-at-a-time
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index bd1e021203fce9b7ec3d2fcfa552a0cac0d7625d..b4d50fbe38e6f6d6a04f87509a20bf131dd9ba5c 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext2
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
 FEATURES:=ext2
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk