Added package ssltunnel, thanks to Eric (emss)
authorFlorian Fainelli <florian@openwrt.org>
Thu, 26 Jan 2006 10:36:21 +0000 (10:36 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 26 Jan 2006 10:36:21 +0000 (10:36 +0000)
SVN-Revision: 3046

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/ssltunnel/Config.in [new file with mode: 0644]
openwrt/package/ssltunnel/Makefile [new file with mode: 0644]
openwrt/package/ssltunnel/ipkg/ssltunnel.control [new file with mode: 0644]

index be7ae99807433e51704d743f953fb5c491089348..ce27676ed1fe6fd9ad6b58d2dc8db58dffbe0099 100644 (file)
@@ -130,6 +130,7 @@ source "package/slurm/Config.in"
 source "package/snort/Config.in"
 source "package/snort-wireless/Config.in"
 source "package/socat/Config.in"
+source "package/ssltunnel/Config.in"
 source "package/ssmtp/Config.in"
 source "package/srelay/Config.in"
 source "package/tmsnc/Config.in"
index ad341ae7318695b10164a788d33096caf1bebe7e..0f1645873e7caff2da37e5aaadad1d91014e9db7 100644 (file)
@@ -210,6 +210,7 @@ package-$(BR2_COMPILE_SPEEX) += speex
 package-$(BR2_COMPILE_SQLITE) += sqlite
 package-$(BR2_COMPILE_SQLITE2) += sqlite2
 package-$(BR2_PACKAGE_SSMTP) += ssmtp
+package-$(BR2_PACKAGE_SSLTUNNEL) += ssltunnel
 package-$(BR2_PACKAGE_SRELAY) += srelay
 package-$(BR2_PACKAGE_STRACE) += strace
 package-$(BR2_PACKAGE_TCPDUMP) += tcpdump
@@ -344,6 +345,7 @@ sipsak-compile: openssl-compile
 socat-compile: openssl-compile
 sqlite-compile: ncurses-compile readline-compile
 sqlite2-compile: ncurses-compile readline-compile
+ssltunnel-compile: openssl-compile ppp-compile
 tcpdump-compile: libpcap-compile
 tinc-compile: zlib-compile openssl-compile liblzo-compile
 tor-compile: libevent-compile openssl-compile zlib-compile
diff --git a/openwrt/package/ssltunnel/Config.in b/openwrt/package/ssltunnel/Config.in
new file mode 100644 (file)
index 0000000..308fa6f
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_SSLTUNNEL
+       prompt "ssltunnel ........................A PPP over SSL vpn tool"
+       tristate
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_OPENSSL
+       select BR2_PACKAGE_PPP
+       help
+         A PPP over SSL vpn tool
+         
+         http://www.hsc.fr/ressources/outils/ssltunnel/index.html
+         
diff --git a/openwrt/package/ssltunnel/Makefile b/openwrt/package/ssltunnel/Makefile
new file mode 100644 (file)
index 0000000..6c3a6bc
--- /dev/null
@@ -0,0 +1,70 @@
+# $Id: Makefile 1188 2005-01-26 17:11:27Z florian $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ssltunnel
+PKG_VERSION:=1.15
+PKG_RELEASE:=1
+PKG_MD5SUM:=bfe529edb9b6c97bc03d213676b1f35d
+
+PKG_SOURCE_URL:=http://www.hsc.fr/ressources/outils/ssltunnel/download
+PKG_SOURCE:=${PKG_NAME}-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,SSLTUNNEL,ssltunnel,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               BUILD_CC=$(TARGET_CC) HOSTCC=$(HOSTCC) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               ./configure \
+               --target=$(GNU_TARGET_NAME) \
+               --host=$(GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
+               --program-prefix="" \
+               --program-suffix="" \
+               --prefix=/usr \
+               --exec-prefix=/usr \
+               --bindir=/usr/bin \
+               --datadir=/usr/share \
+               --includedir=/usr/include \
+               --infodir=/usr/share/info \
+               --libdir=/usr/lib \
+               --libexecdir=/usr/lib \
+               --localstatedir=/var \
+               --mandir=/usr/share/man \
+               --sbindir=/usr/sbin \
+               --sysconfdir=/etc \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CCOPT="$(TARGET_CFLAGS)" INCLS="-I. -I$(STAGING_DIR)/usr/include" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+       touch $@
+
+$(IPKG_SSLTUNNEL):
+       install -m0755 -d $(IDIR_SSLTUNNEL)/usr/bin
+       install -m0755 -d $(IDIR_SSLTUNNEL)/usr/sbin
+       install -m0755 -d $(IDIR_SSLTUNNEL)/usr/lib
+       install -m0755 $(PKG_INSTALL_DIR)/usr/bin/pppclient $(IDIR_SSLTUNNEL)/usr/bin/
+       install -m0755 $(PKG_INSTALL_DIR)/usr/sbin/pppwho $(IDIR_SSLTUNNEL)/usr/sbin/
+       install -m0755 $(PKG_INSTALL_DIR)/usr/lib/pppserver $(IDIR_SSLTUNNEL)/usr/lib/
+       $(RSTRIP) $(IDIR_SSLTUNNEL)
+       $(IPKG_BUILD) $(IDIR_SSLTUNNEL) $(PACKAGE_DIR)
+
+mostlyclean:
+       make -C $(PKG_BUILD_DIR) clean
+       rm $(PKG_BUILD_DIR)/.built
diff --git a/openwrt/package/ssltunnel/ipkg/ssltunnel.control b/openwrt/package/ssltunnel/ipkg/ssltunnel.control
new file mode 100644 (file)
index 0000000..3f99805
--- /dev/null
@@ -0,0 +1,5 @@
+Package: ssltunnel
+Priority: optional
+Section: net
+Description: A PPP over SSL vpn tool
+Depends: openssl, ppp