[packages] tftp-hpa: Add missing libreadline dependency, disable tcpwrappers, bump...
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>
Fri, 14 Aug 2009 13:25:19 +0000 (13:25 +0000)
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>
Fri, 14 Aug 2009 13:25:19 +0000 (13:25 +0000)
SVN-Revision: 17255

net/tftp-hpa/Makefile

index 57a253ea3f04a014d747e6624e747ce6b03ef3c0..0adddf12255ffeecda48bec225066939fe519823 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tftp-hpa
 PKG_VERSION:=0.48
 
 PKG_NAME:=tftp-hpa
 PKG_VERSION:=0.48
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@KERNEL/software/network/tftp
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@KERNEL/software/network/tftp
@@ -20,6 +20,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/tftp-hpa/Default
   SECTION:=net
   CATEGORY:=Network
 define Package/tftp-hpa/Default
   SECTION:=net
   CATEGORY:=Network
+  DEPENDS:=+libreadline
   URL:=http://www.kernel.org/pub/software/network/tftp
 endef
 
   URL:=http://www.kernel.org/pub/software/network/tftp
 endef
 
@@ -35,7 +36,7 @@ endef
 
 define Build/Configure 
        $(call Build/Configure/Default, \
 
 define Build/Configure 
        $(call Build/Configure/Default, \
-               , \
+               --without-tcpwrappers, \
                CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
        )
 endef
                CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
        )
 endef