[packages] utils/bash: add bash to /etc/shells upon installation
authorAndy Boyett <agb@openwrt.org>
Wed, 19 Nov 2008 11:17:56 +0000 (11:17 +0000)
committerAndy Boyett <agb@openwrt.org>
Wed, 19 Nov 2008 11:17:56 +0000 (11:17 +0000)
SVN-Revision: 13287

utils/bash/Makefile

index 7fa750b9913bcdee3df2b8b62ffce971e641fd2f..2787494dac4158d66964022083acd0ec78116e9d 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bash
 PKG_VERSION:=3.2
 
 PKG_NAME:=bash
 PKG_VERSION:=3.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.gnu.org/gnu/bash/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.gnu.org/gnu/bash/
@@ -33,7 +33,7 @@ define Package/bash/description
 endef
 
 
 endef
 
 
-define Build/Configure 
+define Build/Configure
        $(call Build/Configure/Default, \
                --disable-restricted \
                --without-bash-malloc \
        $(call Build/Configure/Default, \
                --disable-restricted \
                --without-bash-malloc \
@@ -50,6 +50,12 @@ define Build/Compile
                all install
 endef
 
                all install
 endef
 
+define Package/bash/postinst
+#!/bin/sh
+grep bash $${IPKG_INSTROOT}/etc/shells || \
+       echo "/bin/bash" >> $${IPKG_INSTROOT}/etc/shells
+endef
+
 define Package/bash/install
        $(INSTALL_DIR) $(1)/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/bash $(1)/bin/
 define Package/bash/install
        $(INSTALL_DIR) $(1)/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/bash $(1)/bin/