package/kernel: add package for the Gianfar PTP driver
authorGabor Juhos <juhosg@openwrt.org>
Wed, 20 Feb 2013 19:14:20 +0000 (19:14 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 20 Feb 2013 19:14:20 +0000 (19:14 +0000)
PTP for gianfar can be built as a module. Create a package for it.

[juhosg: remove the mp85xx specific patch]

Patchwork: http://patchwork.openwrt.org/patch/3344/
Signed-off-by: Wojciech Dubowik <Wojciech.Dubowik@neratec.com>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 35706

package/kernel/modules/other.mk

index f63d6705d98a5e929e6ca92af753d92164bc7f87..13a0ec4afc351bb098f3393e05f9896d322c0bf2 100644 (file)
@@ -636,3 +636,20 @@ define KernelPacakge/ptp/description
 endef
 
 $(eval $(call KernelPackage,ptp))
 endef
 
 $(eval $(call KernelPackage,ptp))
+
+
+define KernelPackage/ptp-gianfar
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Freescale Gianfar PTP support
+  DEPENDS:=@TARGET_mpc85xx +kmod-gianfar +kmod-ptp
+  KCONFIG:=CONFIG_PTP_1588_CLOCK_GIANFAR
+  FILES:=$(LINUX_DIR)/drivers/net/ethernet/freescale/gianfar_ptp.ko
+  AUTOLOAD:=$(call AutoLoad,51,gianfar_ptp)
+endef
+
+define KernelPacakge/ptp-gianfar/description
+  Kernel module for IEEE 1588 support for Freescale
+  Gianfar Ethernet drivers.
+endef
+
+$(eval $(call KernelPackage,ptp-gianfar))