adds wnck package
authorJohn Crispin <john@openwrt.org>
Mon, 9 Jun 2008 20:16:17 +0000 (20:16 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 9 Jun 2008 20:16:17 +0000 (20:16 +0000)
SVN-Revision: 11418

libs/wnck/Makefile [new file with mode: 0644]

diff --git a/libs/wnck/Makefile b/libs/wnck/Makefile
new file mode 100644 (file)
index 0000000..7386647
--- /dev/null
@@ -0,0 +1,61 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libwnck
+PKG_VERSION:=2.18.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://ftp.gnome.org/pub/gnome/sources/libwnck/2.18/
+PKG_FIXUP:=libtool
+
+include $(INCLUDE_DIR)/package.mk
+
+EXTRA_CFLAGS+= -I$(STAGING_DIR)/usr/lib/libintl/include/ -I$(STAGING_DIR)/usr/lib/libiconv/include/
+EXTRA_LDFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
+define Package/libwnck
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=Window Navigator Construction Kit
+  URL:=http://ftp.gnome.org/
+  DEPENDS:=
+endef
+
+define Package/libwnck/description
+  window Navigator Construction Kit
+endef
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); \
+               if [ -x $(CONFIGURE_CMD) ]; then \
+                       $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
+                       GMSGFMT=msgfmt \
+                       $(CONFIGURE_VARS) \
+                       $(CONFIGURE_CMD) \
+                       $(CONFIGURE_ARGS) ;\
+               fi \
+       )
+endef
+
+define Build/Compile
+       cd $(PKG_BUILD_DIR) ; DESTDIR=$(PKG_INSTALL_DIR) $(MAKE) all install
+endef
+
+define Build/InstallDev
+       mkdir -p $(1)
+       cp -r $(PKG_INSTALL_DIR)/* $(1)
+endef
+
+define Package/libwnck/install
+       mkdir -p $(1)
+       cp -r $(PKG_INSTALL_DIR)/* $(1)
+endef
+
+$(eval $(call BuildPackage,libwnck))