just build polipo, not all info and html docs, mark polipo.conf as a conffile
authorNicolas Thill <nico@openwrt.org>
Sun, 16 Sep 2007 16:57:12 +0000 (16:57 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 16 Sep 2007 16:57:12 +0000 (16:57 +0000)
SVN-Revision: 8807

ipv6/polipo/Makefile

index e279f465ac4f4ba0f0b3910d75273c5c77723e5b..6446dacb5917145f55e073f2df9c30de6defa28e 100644 (file)
@@ -36,15 +36,18 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                CFLAGS="$(TARGET_CFLAGS)" \
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                CFLAGS="$(TARGET_CFLAGS)" \
-               all
+               polipo
+endef
+
+define Package/polipo/conffiles
+/etc/polipo/polipo.conf
 endef
 
 define Package/polipo/install
        $(INSTALL_DIR) $(1)/usr/sbin
 endef
 
 define Package/polipo/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/var/cache/$(PKG_NAME)
-       $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)
-       $(INSTALL_CONF) $(PKG_BUILD_DIR)/config.sample $(1)/etc/$(PKG_NAME)/$(PKG_NAME).conf
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/polipo $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/polipo
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/config.sample $(1)/etc/polipo/polipo.conf
 endef
 
 $(eval $(call BuildPackage,polipo))
 endef
 
 $(eval $(call BuildPackage,polipo))