include: fix prereq tests for perl and file (#18911)
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 6 Feb 2015 17:38:54 +0000 (17:38 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 6 Feb 2015 17:38:54 +0000 (17:38 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44296

include/prereq-build.mk

index 7945f05..926a06f 100644 (file)
@@ -132,7 +132,7 @@ $(eval $(call SetupHostCommand,wget,Please install GNU 'wget', \
        wget --version | grep GNU))
 
 $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
-       perl --version | grep "perl 5"))
+       perl --version | grep "perl.*v5"))
 
 $(eval $(call SetupHostCommand,python,Please install Python 2.x, \
        python2.7 -V 2>&1 | grep Python, \
@@ -146,7 +146,7 @@ $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.6.5, \
        git clone 2>&1 | grep -- --recursive))
 
 $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
-       file --version | grep file))
+       file --version 2>&1 | grep file))
 
 $(eval $(call SetupHostCommand,openssl,Please install the 'openssl' utility, \
        openssl version | grep OpenSSL))