fs-tools: add back mount_root, jffs2reset and ffs2mark functionality
authorJohn Crispin <john@openwrt.org>
Tue, 25 Mar 2014 20:15:50 +0000 (20:15 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 25 Mar 2014 20:15:50 +0000 (20:15 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 40018

package/system/fstools/Makefile
package/system/fstools/files/jffs2mark [new file with mode: 0644]
package/system/fstools/files/jffs2reset [new file with mode: 0644]
package/system/fstools/files/mount_root [new file with mode: 0644]

index 9a6aaeef1ed4ffb21481aa1a3fad10b6b60f3a2c..c16d6a562106dcd82c3b80c9eac24ec9c1d442b3 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fstools
-PKG_VERSION:=2014-02-27
+PKG_VERSION:=2014-03-25
 
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
@@ -39,6 +39,7 @@ endef
 define Package/fstools/install
        $(INSTALL_DIR) $(1)/sbin
 
+       $(INSTALL_BIN) ./files/{jffs2reset,jffs2mark,mount_root} $(1)/sbin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/fs-state $(1)/sbin/
        $(INSTALL_BIN) ./files/snapshot $(1)/sbin/
 endef
diff --git a/package/system/fstools/files/jffs2mark b/package/system/fstools/files/jffs2mark
new file mode 100644 (file)
index 0000000..d0bc7ad
--- /dev/null
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+fs-state overlay jffs2mark
diff --git a/package/system/fstools/files/jffs2reset b/package/system/fstools/files/jffs2reset
new file mode 100644 (file)
index 0000000..cc3a845
--- /dev/null
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+fs-state overlay jffs2reset
diff --git a/package/system/fstools/files/mount_root b/package/system/fstools/files/mount_root
new file mode 100644 (file)
index 0000000..860c194
--- /dev/null
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+fs-state start