build: consider sub-directories when deploying packages to image with CONFIG_PER_FEED...
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 7 Aug 2014 15:35:12 +0000 (15:35 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 7 Aug 2014 15:35:12 +0000 (15:35 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 42041

package/Makefile

index bf1b16fc9a255952c558e40764118d46be0f751e..0cba87857646a56b4effbce32c762c51251f3ff1 100644 (file)
@@ -94,7 +94,7 @@ $(curdir)/install: $(TMP_DIR)/.build
        - find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755
        rm -rf $(TARGET_DIR)
        [ -d $(TARGET_DIR)/tmp ] || mkdir -p $(TARGET_DIR)/tmp
-       @$(FIND) `sed -e 's|.*|$(PACKAGE_DIR)/&_*.ipk|' $(PACKAGE_INSTALL_FILES)` | sort -u | $(OPKG) install
+       @$(FIND) `sed -e 's|.*|$(PACKAGE_DIR)$(if $(CONFIG_PER_FEED_REPO),/*)/&_*.ipk|' $(PACKAGE_INSTALL_FILES)` | sort -u | $(OPKG) install
        @for file in $(PACKAGE_INSTALL_FILES); do \
                [ -s $$file.flags ] || continue; \
                for flag in `cat $$file.flags`; do \