toolchain/gcc: fix installing the toolchain after removing the toolchain dir without...
authorFelix Fietkau <nbd@openwrt.org>
Sat, 30 Jun 2012 18:12:19 +0000 (18:12 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 30 Jun 2012 18:12:19 +0000 (18:12 +0000)
SVN-Revision: 32554

toolchain/gcc/final/Makefile

index b0fe20023b608c183d2d60dd500276796d0f926d..59a5b2497c12201ea4acd5d125e3fde38fb71fe8 100644 (file)
@@ -28,14 +28,19 @@ ifneq ($(CONFIG_SJLJ_EXCEPTIONS),)
        --enable-sjlj-exceptions
 endif
 
        --enable-sjlj-exceptions
 endif
 
-define Host/Configure
-       mkdir -p $(GCC_BUILD_DIR) $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)
+define CleanupToolchain
+       $(INSTALL_DIR) $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)
        # Important!  Required for limits.h to be fixed.
        rm -rf $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/sys-include
        ln -sf ../include $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/sys-include
        rm -rf $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/lib
        ln -sf ../lib $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/lib
        $(if $(CONFIG_mips64)$(CONFIG_mips64el)$(CONFIG_x86_64),ln -sf ../lib64 $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/lib64)
        # Important!  Required for limits.h to be fixed.
        rm -rf $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/sys-include
        ln -sf ../include $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/sys-include
        rm -rf $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/lib
        ln -sf ../lib $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/lib
        $(if $(CONFIG_mips64)$(CONFIG_mips64el)$(CONFIG_x86_64),ln -sf ../lib64 $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/lib64)
+endef
+
+define Host/Configure
+       $(CleanupToolchain)
+       mkdir -p $(GCC_BUILD_DIR)
        (cd $(GCC_BUILD_DIR) && rm -f config.cache; \
                $(GCC_CONFIGURE) \
        );
        (cd $(GCC_BUILD_DIR) && rm -f config.cache; \
                $(GCC_CONFIGURE) \
        );
@@ -59,6 +64,7 @@ define SetupExtraArch
 endef
 
 define Host/Install
 endef
 
 define Host/Install
+       $(CleanupToolchain)
        $(_SINGLE)$(GCC_MAKE) -C $(GCC_BUILD_DIR) install
        # Set up the symlinks to enable lying about target name.
        set -e; \
        $(_SINGLE)$(GCC_MAKE) -C $(GCC_BUILD_DIR) install
        # Set up the symlinks to enable lying about target name.
        set -e; \