backfire: ar71xx: create separate 'factory' and 'sysupgrade' images for the Planex...
authorGabor Juhos <juhosg@openwrt.org>
Wed, 28 Apr 2010 10:46:38 +0000 (10:46 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 28 Apr 2010 10:46:38 +0000 (10:46 +0000)
SVN-Revision: 21230

target/linux/ar71xx/image/Makefile

index 4b340f5685722a280c5ce3d33fbdd8197277740f..f8ecb42c013e1cff20f0278c3da35f943b3b4438 100644 (file)
@@ -273,13 +273,13 @@ define Image/Build/Planex
                        -d $(KDIR)/vmlinux-$(2).bin.gz $(KDIR)/vmlinux-$(2).uImage; \
                ( \
                        dd if=$(KDIR)/vmlinux-$(2).uImage bs=1408k conv=sync; \
-                       dd if=$(KDIR)/root.$(1) bs=6208k conv=sync; \
-               ) > $(call imgname,$(1),$(2)).bin; \
+                       dd if=$(KDIR)/root.$(1); \
+               ) > $(call imgname,$(1),$(2))-sysupgrade.bin; \
                $(STAGING_DIR_HOST)/bin/mkplanexfw \
                        -B $(2) \
                        -v 2.00.00 \
-                       -i $(call imgname,$(1),$(2)).bin \
-                       -o $(call imgname,$(1),$(2)).webui; \
+                       -i $(call imgname,$(1),$(2))-sysupgrade.bin \
+                       -o $(call imgname,$(1),$(2))-factory.bin; \
        fi; fi
 endef