Device Tree Compiler require more recent bison ...
authorRalph Hempel <ralph.hempel@lantiq.com>
Tue, 5 Feb 2008 19:39:57 +0000 (19:39 +0000)
committerRalph Hempel <ralph.hempel@lantiq.com>
Tue, 5 Feb 2008 19:39:57 +0000 (19:39 +0000)
SVN-Revision: 10398

tools/Makefile
tools/bison/Makefile [new file with mode: 0644]

index 022bbe1e9d64f2bdaa37e437c28638912c462f4d..a73a79fcca7a3f73e84fb13359a240fd5136d5db 100644 (file)
@@ -9,7 +9,7 @@
 curdir:=tools
 
 # subdirectories to descend into
-$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache) dtc
+$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache) bison dtc
 
 # builddir dependencies
 $(curdir)/squashfs/compile := $(curdir)/lzma/install
diff --git a/tools/bison/Makefile b/tools/bison/Makefile
new file mode 100644 (file)
index 0000000..2b85612
--- /dev/null
@@ -0,0 +1,33 @@
+# 
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bison
+PKG_VERSION:=2.3
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=ftp://ftp.gnu.org/gnu/$(PKG_NAME)
+PKG_MD5SUM:=22327efdd5080e2b1acb6e560a04b43a
+PKG_CAT:=zcat
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Build/Install
+       $(MAKE) -C $(PKG_BUILD_DIR) install
+endef
+
+define Build/Clean
+       $(MAKE) -C $(PKG_BUILD_DIR) uninstall
+       $(MAKE) -C $(PKG_BUILD_DIR) clean
+       $(call Build/Clean/Default)
+endef
+
+$(eval $(call HostBuild))