[packages] tinyproxy: update to v1.8.0 (#6563)
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 24 Jan 2010 20:47:39 +0000 (20:47 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 24 Jan 2010 20:47:39 +0000 (20:47 +0000)
SVN-Revision: 19319

net/tinyproxy/Makefile
net/tinyproxy/patches/100-fix_typo.patch [deleted file]
net/tinyproxy/patches/120-fix_INET6.patch [new file with mode: 0644]

index 2ba7ddc30af351167f5ece7f035673ba686fff5f..5a16f663eb5acd737b548fd92958d66109ab9aaa 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinyproxy
-PKG_VERSION:=1.6.5
+PKG_VERSION:=1.8.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.banu.com/pub/tinyproxy/1.6/
-PKG_MD5SUM:=2b2862ba33d2939e4572688d442ba415
+PKG_SOURCE_URL:=http://www.banu.com/pub/tinyproxy/1.8/
+PKG_MD5SUM:=09843d47828261394d0a30af0b058997
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -31,7 +31,8 @@ endef
 
 CONFIGURE_ARGS+= \
        --enable-filter \
-       --enable-transparent-proxy \
+       --enable-transparent \
+       --enable-regexcheck=no \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
diff --git a/net/tinyproxy/patches/100-fix_typo.patch b/net/tinyproxy/patches/100-fix_typo.patch
deleted file mode 100644 (file)
index 82fb6f1..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/reqs.c
-+++ b/src/reqs.c
-@@ -726,7 +726,7 @@ process_request(struct conn_s *connptr, 
-                                           request->host);
-                       indicate_http_error(connptr, 403, "Filtered",
--                                          "detail", "The request you made has been filted",
-+                                          "detail", "The request you made has been filtered",
-                                           "url", url,
-                                           NULL);
diff --git a/net/tinyproxy/patches/120-fix_INET6.patch b/net/tinyproxy/patches/120-fix_INET6.patch
new file mode 100644 (file)
index 0000000..0853cfe
--- /dev/null
@@ -0,0 +1,38 @@
+--- a/src/sock.c
++++ b/src/sock.c
+@@ -39,8 +39,7 @@
+  * returned if the bind succeeded.  Otherwise, -1 is returned
+  * to indicate an error.
+  */
+-static int
+-bind_socket (int sockfd, const char *addr, int family)
++static int bind_socket (int sockfd, const char *addr)
+ {
+         struct addrinfo hints, *res, *ressave;
+@@ -48,7 +47,7 @@ bind_socket (int sockfd, const char *addr, int family)
+         assert (addr != NULL && strlen (addr) != 0);
+         memset (&hints, 0, sizeof (struct addrinfo));
+-        hints.ai_family = family;
++        hints.ai_family = AF_UNSPEC;
+         hints.ai_socktype = SOCK_STREAM;
+         /* The local port it not important */
+@@ -106,14 +105,12 @@ int opensock (const char *host, int port, const char *bind_to)
+                 /* Bind to the specified address */
+                 if (bind_to) {
+-                        if (bind_socket (sockfd, bind_to,
+-                                         res->ai_family) < 0) {
++                        if (bind_socket (sockfd, bind_to) < 0) {
+                                 close (sockfd);
+                                 continue;       /* can't bind, so try again */
+                         }
+                 } else if (config.bind_address) {
+-                        if (bind_socket (sockfd, config.bind_address,
+-                                         res->ai_family) < 0) {
++                        if (bind_socket (sockfd, config.bind_address) < 0) {
+                                 close (sockfd);
+                                 continue;       /* can't bind, so try again */
+                         }