Update stress to 1.0.0 (#3697)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 5 Jul 2008 10:23:59 +0000 (10:23 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 5 Jul 2008 10:23:59 +0000 (10:23 +0000)
SVN-Revision: 11635

utils/stress/Makefile

index ab2c03c54bbfb1e166d22998a59fa4be77ce7fd7..dd06b5e48ff638b903bfd937bef0ee1b53b8c598 100644 (file)
@@ -8,14 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=stress
-PKG_VERSION:=0.18.9
+PKG_VERSION:=1.0.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://weather.ou.edu/~apw/projects/stress/
-PKG_MD5SUM:=e6fba31fbac8d0a1b359c7e25cba8e3f
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=d693ff044ac7d34f8aaea202cd96f679
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,7 +26,8 @@ define Package/stress
 endef
 
 define Package/stress/description
-       stress is a simple tool that imposes certain types of compute \ stress on UNIX-like operating systems.
+       stress is a simple tool that imposes certain types of compute \ stress
+       on UNIX-like operating systems.
 endef
 
 CONFIGURE_ARGS += \
@@ -38,8 +37,8 @@ MAKE_FLAGS += \
        CFLAGS="$(TARGET_CFLAGS)"
 
 define Package/stress/install
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_BUILD_DIR)/src/stress $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/stress $(1)/usr/bin
 endef
 
 $(eval $(call BuildPackage,stress))