[dropbear]
authorJohn Crispin <john@openwrt.org>
Fri, 1 Apr 2011 10:55:23 +0000 (10:55 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 1 Apr 2011 10:55:23 +0000 (10:55 +0000)
r25831 reduced the size of the dropbear executable by, among other things,
disabling support for keyboard-interactive authentication. The default
sshd configuration on Mac OS X only permits keyboard-interactive and
public-key authentication, so unless a public key is set up, the default
OpenWrt ssh client is now unable to connect to Mac OS X hosts. This patch
re-enables keyboard-interactive authentication.

In my tests, this increases the size of the stripped dropbear executable
by 416 bytes on mips and 1,104 bytes on mipsel. In my opinion, such a
small space savings isn't worthwhile when the resultant executable is
severely hamstrung.

Signed-off-by: Mark Mentovai <mark@moxienet.com>
SVN-Revision: 26390

package/dropbear/Makefile
package/dropbear/patches/120-openwrt_options.patch

index 736cf3945c831f2dd57091b22d5c69fbce379097..3fba1347ef29f4f3b5ff18fa230d07fc02d9d2c0 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dropbear
 PKG_VERSION:=0.53.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
index bfae5b9772fc65421266bf6c6bcae5cf21611982..d1745e1e8d0cee19f7216793746a3cf9df10b7ff 100644 (file)
  
  /* The MOTD file path */
  #ifndef MOTD_FILENAME
-@@ -177,7 +177,7 @@ much traffic. */
- #define ENABLE_CLI_PASSWORD_AUTH
- #define ENABLE_CLI_PUBKEY_AUTH
--#define ENABLE_CLI_INTERACT_AUTH
-+/*#define ENABLE_CLI_INTERACT_AUTH*/
- /* This variable can be used to set a password for client
-  * authentication on the commandline. Beware of platforms
 @@ -185,7 +185,7 @@ much traffic. */
   * note that it will be provided for all "hidden" client-interactive
   * style prompts - if you want something more sophisticated, use