[toolchain] remove support for disabling large file support, it is broken, breaks...
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 28 Jan 2011 17:00:43 +0000 (17:00 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 28 Jan 2011 17:00:43 +0000 (17:00 +0000)
SVN-Revision: 25208

Config.in
rules.mk

index a634328074daa493add6264460b0cbbad3516fc5..c9ef24a63dcc126e346db40780bcdc4f9469fe9f 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -140,13 +140,6 @@ menu "Global build settings"
                  In case software provides optional support for patented functionality,
                  this optional support will get disabled for this package.
 
-       config LARGEFILE
-               bool
-               prompt "Enable large file (files > 2 GB) support"
-               default y
-               help
-                 Enable large file (files > 2 GB) support.
-
        config SHADOW_PASSWORDS
                bool
                prompt "Enable shadow password support"
index 2e66bea4cfeba80e2b01bca636a2b6732c13b9d4..1a9bfc859abbb2c6eff6b77d4395b8c10b7af37c 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -231,12 +231,6 @@ else
   DISABLE_IPV6:=--disable-ipv6
 endif
 
-ifeq ($(CONFIG_LARGEFILE),y)
-  DISABLE_LARGEFILE:=
-else
-  DISABLE_LARGEFILE:=--disable-largefile
-endif
-
 ifeq ($(CONFIG_TAR_VERBOSITY),y)
   TAR_OPTIONS:=-xvf -
 else