[packages] add package 'libssh2' - thanks to Jiri Slachta
authorMirko Vogt <mirko@openwrt.org>
Tue, 7 Feb 2012 11:52:07 +0000 (11:52 +0000)
committerMirko Vogt <mirko@openwrt.org>
Tue, 7 Feb 2012 11:52:07 +0000 (11:52 +0000)
SVN-Revision: 30348

libs/libssh2/Makefile [new file with mode: 0644]

diff --git a/libs/libssh2/Makefile b/libs/libssh2/Makefile
new file mode 100644 (file)
index 0000000..913e11c
--- /dev/null
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libssh2
+PKG_VERSION:=1.4.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.libssh2.org/download/
+PKG_MD5SUM:=ee670161d8c5dff93ae84a3f34f15669
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libssh2
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=SSH2 library
+  URL:=http://www.libssh2.org/
+  DEPENDS:=+libopenssl +zlib
+endef
+
+TARGET_CFLAGS += $(FPIC)
+CONFIGURE_ARGS += --with-libssl-prefix=$(STAGING_DIR)/usr
+
+define Build/Compile
+       $(MAKE) $(MAKE_FLAGS) -C $(PKG_BUILD_DIR)/src all
+endef
+
+define Build/Install
+       $(MAKE) $(MAKE_FLAGS) -C $(PKG_BUILD_DIR)/src install DESTDIR=$(PKG_INSTALL_DIR)
+       $(MAKE) $(MAKE_FLAGS) -C $(PKG_BUILD_DIR) install-includeHEADERS DESTDIR=$(PKG_INSTALL_DIR)
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/include/*h \
+               $(1)/usr/include/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libssh2.so* \
+               $(1)/usr/lib/
+endef
+
+define Package/libssh2/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libssh2.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libssh2))