ppp: remove -ffunction-sections, -fdata-sections and -Wl,--gc-sections, it can cause...
authorFelix Fietkau <nbd@openwrt.org>
Sun, 12 Jun 2011 14:07:08 +0000 (14:07 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 12 Jun 2011 14:07:08 +0000 (14:07 +0000)
SVN-Revision: 27159

package/ppp/Makefile

index 3aefed3142a55d795111f0ee19072cad48533df5..6ee52abc32bf372fb9ffd84b653c64f0f41beed9 100644 (file)
@@ -140,9 +140,6 @@ $(call Build/Configure/Default,, \
                $(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux/
 endef
 
                $(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux/
 endef
 
-TARGET_CFLAGS += -ffunction-sections -fdata-sections
-MAKE_VARS += LDFLAGS="-Wl,--gc-sections"
-
 MAKE_FLAGS += COPTS="$(TARGET_CFLAGS)" \
                PRECOMPILED_FILTER=1 \
                STAGING_DIR="$(STAGING_DIR)"
 MAKE_FLAGS += COPTS="$(TARGET_CFLAGS)" \
                PRECOMPILED_FILTER=1 \
                STAGING_DIR="$(STAGING_DIR)"