makefile cleanup, add missing pygtk prereq check
authorFelix Fietkau <nbd@openwrt.org>
Wed, 6 Aug 2008 02:35:59 +0000 (02:35 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 6 Aug 2008 02:35:59 +0000 (02:35 +0000)
SVN-Revision: 12200

lang/pygtk/Makefile
lang/python-gnome-desktop2/Makefile

index 60a67f9d6a4eff28737464435156ec66a6419349..524394c61b7868a3980ff86c033728467e442313 100644 (file)
@@ -44,13 +44,16 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)
-       cp -r $(PKG_INSTALL_DIR)/* $(1)
+       $(INSTALL_DIR) $(1)
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)
 endef
 
 define Package/python-gtk/install
-       mkdir -p $(1)
-       cp -r $(PKG_INSTALL_DIR)/* $(1)
+       $(INSTALL_DIR) $(1)
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)
 endef
 
 $(eval $(call BuildPackage,python-gtk))
+$(eval $(call RequireCommand,pygtk-codegen-2.0 \
+       Please install the pygtk 2.0 development package \
+))
index afc2096bd71a7540f51f6368129997bfa85ad609..6ee2da166d40c94b051e0c6aeebe8dfab71fc838 100644 (file)
@@ -32,29 +32,16 @@ define Package/gnome-python-desktop/description
   python bindings for gnome
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-               if [ -x $(CONFIGURE_CMD) ]; then \
-                       $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
-                       $(CONFIGURE_VARS) \
-                       $(CONFIGURE_CMD) \
-                       $(CONFIGURE_ARGS) ;\
-               fi \
-       )
-endef
-
-define Build/Compile
-       cd $(PKG_BUILD_DIR) ; DESTDIR=$(PKG_INSTALL_DIR) $(MAKE) all install
-endef
+MAKE_FLAGS += DESTDIR=$(PKG_INSTALL_DIR) all install
 
 define Build/InstallDev
-       mkdir -p $(1)
-       cp -r $(PKG_INSTALL_DIR)/* $(1)
+       $(INSTALL_DIR) $(1)
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)
 endef
 
 define Package/gnome-python-desktop/install
-       mkdir -p $(1)
-       cp -r $(PKG_INSTALL_DIR)/* $(1)
+       $(INSTALL_DIR) $(1)
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)
 endef
 
 $(eval $(call BuildPackage,gnome-python-desktop))