Fix cbtt compilation and pass our cflags
authorFlorian Fainelli <florian@openwrt.org>
Tue, 28 Aug 2007 13:01:49 +0000 (13:01 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 28 Aug 2007 13:01:49 +0000 (13:01 +0000)
SVN-Revision: 8525

net/cbtt/Makefile

index 34025a7228327f369b089bbb6eb06f2590148360..7f0a83ac4865722a2420c62a9a7a2a801e267c41 100644 (file)
@@ -26,7 +26,7 @@ define Package/cbtt
   DEPENDS:=zlib
   MENU:=1
   TITLE:=Bittorrent tracker
   DEPENDS:=zlib
   MENU:=1
   TITLE:=Bittorrent tracker
-  DEPENDS:=+libpthread +uclibcxx
+  DEPENDS:=+libpthread +uclibcxx +libmysqlclient
   DESCRIPTION:=a C BitTorrent Tracker
   URL:=http://bnbtusermods.sourceforge.net
 endef
   DESCRIPTION:=a C BitTorrent Tracker
   URL:=http://bnbtusermods.sourceforge.net
 endef
@@ -41,8 +41,8 @@ define Package/cbtt-mysql
 endef
 
 MAKE_FLAGS += \
 endef
 
 MAKE_FLAGS += \
-       LFLAGS="-L$(STAGING_DIR)/usr/lib -L $(STAGING_DIR)/usr/lib/mysql -L. -lz -lmysqlclient -nodefaultlibs -lpthread -luClibc++ -lc -lm -lgcc" \
-       CFLAGS="-I$(STAGING_DIR)/usr/include -fno-builtin -fno-rtti -nostdinc++"
+       LFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/usr/lib/mysql -L. -lz -lmysqlclient -nodefaultlibs -lpthread -luClibc++ -lc -lm -lgcc" \
+       CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -fno-builtin -fno-rtti -nostdinc++"
 
 define Package/cbtt/install
        $(INSTALL_DIR) $(1)/usr/bin
 
 define Package/cbtt/install
        $(INSTALL_DIR) $(1)/usr/bin