package-defaults: remove libssp for musl (redundant)
authorSteven Barth <cyrus@openwrt.org>
Sat, 20 Jun 2015 17:37:22 +0000 (17:37 +0000)
committerSteven Barth <cyrus@openwrt.org>
Sat, 20 Jun 2015 17:37:22 +0000 (17:37 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
SVN-Revision: 46072

include/package-defaults.mk

index 2896b4c..a5e9fbe 100644 (file)
@@ -5,7 +5,7 @@
 # See /LICENSE for more information.
 #
 
-PKG_DEFAULT_DEPENDS = +libc +SSP_SUPPORT:libssp +USE_GLIBC:librt +USE_GLIBC:libpthread
+PKG_DEFAULT_DEPENDS = +libc +(SSP_SUPPORT&&!USE_MUSL):libssp +USE_GLIBC:librt +USE_GLIBC:libpthread
 
 ifneq ($(PKG_NAME),toolchain)
   PKG_FIXUP_DEPENDS = $(if $(filter kmod-%,$(1)),$(2),$(PKG_DEFAULT_DEPENDS) $(filter-out $(PKG_DEFAULT_DEPENDS),$(2)))