malta: set CPU_TYPE:=24kc.
authorFelix Fietkau <nbd@openwrt.org>
Sat, 31 Oct 2015 09:30:14 +0000 (09:30 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 31 Oct 2015 09:30:14 +0000 (09:30 +0000)
There are instructions (e.g. wsbh) only available in MIPS32R2 which is
the isa level used by many MIPS targets in OpenWrt.  As we use the malta
target mostly for development and testing purposes, setting the CPU_TYPE
to 24Kc will make the emulation more real.

The following is output from qemu-system-mipsel 2.3.0

    root@OpenWrt:/# cat /proc/cpuinfo  | grep 'cpu model\|isa'
    cpu model               : MIPS 24Kc V0.0  FPU V0.0
    isa                     : mips1 mips2 mips32r1 mips32r2

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
SVN-Revision: 47324

target/linux/malta/Makefile

index 06cb68aee4427e0f8069771e154e2795dc421b7e..c9f1586aaacbde480660d58048f3867c1fbaa4f7 100644 (file)
@@ -8,6 +8,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=malta
 BOARDNAME:=MIPS Malta CoreLV board (qemu)
+CPU_TYPE:=24kc
 SUBTARGETS:=le be #le64 be64
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>