[package] update bahamut to 1.8.6 (#5546)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 18 Jul 2009 08:32:38 +0000 (08:32 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 18 Jul 2009 08:32:38 +0000 (08:32 +0000)
SVN-Revision: 16891

net/bahamut/Makefile
net/bahamut/patches/001-cross_compile.patch
net/bahamut/patches/002-glibc_fix.patch

index 4cfee71e7c288e84020dc95195eb7c0f39b52710..43954c92cd031856bae0be7b9b1edf4c487e8228 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bahamut
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bahamut
-PKG_VERSION:=1.8.4
+PKG_VERSION:=1.8.6
 PKG_RELEASE:=1
 PKG_RELEASE:=1
-PKG_MD5SUM:=6b9a805f4408f3887e75a9d14c69ab93
 
 
-PKG_SOURCE_URL:=http://bahamut.dal.net/download/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-release.tar.gz
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-release.tar.gz
+PKG_SOURCE_URL:=http://bahamut.dal.net/download
+PKG_MD5SUM:=a814a4e0ff1fabcf026ea8574b4a1e20
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -46,7 +46,7 @@ define Build/Compile
        )
 endef
 
        )
 endef
 
-define Package/bahamut/install 
+define Package/bahamut/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ircd $(1)/usr/sbin
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ircd $(1)/usr/sbin
index 7ed3729779aa8adc99a3f4ab53c663ed04fa7b6a..ee398b0a89a9f2dcacf3de559b0ce4b6760d86d2 100644 (file)
@@ -1,10 +1,10 @@
 --- a/Makefile.in
 +++ b/Makefile.in
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -23,8 +23,8 @@
+@@ -22,8 +22,8 @@ MV=@MV@
  ENGINE=@SENGINE@
  
  SHELL=/bin/sh
  ENGINE=@SENGINE@
  
  SHELL=/bin/sh
--SUBDIRS=zlib src doc tools
+-SUBDIRS=src doc tools
 -INSTDIRS=src doc tools
 +SUBDIRS=src
 +INSTDIRS=src doc
 -INSTDIRS=src doc tools
 +SUBDIRS=src
 +INSTDIRS=src doc
@@ -13,7 +13,7 @@
  CC=@CC@
 --- a/configure
 +++ b/configure
  CC=@CC@
 --- a/configure
 +++ b/configure
-@@ -6197,8 +6197,7 @@
+@@ -7057,8 +7057,7 @@ echo $ECHO_N "checking for epoll_create 
    { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
    { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
 +See \`config.log' for more details." >&2;} }
  else
    cat >conftest.$ac_ext <<_ACEOF
 +See \`config.log' for more details." >&2;} }
  else
    cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
+ /* confdefs.h.  */
 --- a/src/Makefile.in
 +++ b/src/Makefile.in
 @@ -1,8 +1,8 @@
  CC=@CC@
  RM=@RM@
  MV=@MV@
 --- a/src/Makefile.in
 +++ b/src/Makefile.in
 @@ -1,8 +1,8 @@
  CC=@CC@
  RM=@RM@
  MV=@MV@
--IRCDLIBS=@LIBS@ ../zlib/libz.a
+-IRCDLIBS=@LIBS@ 
 -INCLUDEDIR=-I../include
 +IRCDLIBS=-lresolv -lz @LIBS@ -L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib
 +INCLUDEDIR=-I../include -I$(STAGING_DIR)/usr/include
  OPENSSLINC=@SSL_INCLUDES@
  ENGINE=@SENGINE@
  CRYPTO=@ENCRYPT_SRC@
 -INCLUDEDIR=-I../include
 +IRCDLIBS=-lresolv -lz @LIBS@ -L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib
 +INCLUDEDIR=-I../include -I$(STAGING_DIR)/usr/include
  OPENSSLINC=@SSL_INCLUDES@
  ENGINE=@SENGINE@
  CRYPTO=@ENCRYPT_SRC@
-@@ -11,10 +11,10 @@
+@@ -11,10 +11,10 @@ INSTALL_BIN=@INSTALL_PROGRAM@
  INSTALL_DIR=@INSTALL_DIR@
  INSTALL_DIR=@INSTALL_DIR@
- CFLAGS=@CFLAGS@
+ CFLAGS=@CFLAGS@ -fno-strict-aliasing
  
 -RES_SRC =
 +#RES_SRC =
  
 -RES_SRC =
 +#RES_SRC =
@@ -49,7 +49,7 @@
  
  SOURCES = blalloc.c bsd.c channel.c clientlist.c clones.c confparse.c \
            fdlist.c fds.c hash.c hide.c inet_addr.c ircd.c ircsprintf.c \
  
  SOURCES = blalloc.c bsd.c channel.c clientlist.c clones.c confparse.c \
            fdlist.c fds.c hash.c hide.c inet_addr.c ircd.c ircsprintf.c \
-@@ -22,7 +22,7 @@
+@@ -22,7 +22,7 @@ SOURCES = blalloc.c bsd.c channel.c clie
            m_who.c match.c memcount.c modules.c packet.c parse.c pcre.c \
            probability.c res.c s_auth.c s_bsd.c s_conf.c s_debug.c s_err.c \
            s_misc.c s_numeric.c s_serv.c s_user.c sbuf.c scache.c send.c \
            m_who.c match.c memcount.c modules.c packet.c parse.c pcre.c \
            probability.c res.c s_auth.c s_bsd.c s_conf.c s_debug.c s_err.c \
            s_misc.c s_numeric.c s_serv.c s_user.c sbuf.c scache.c send.c \
@@ -60,7 +60,7 @@
  OBJECTS = $(SOURCES:.c=.o) version.o
 --- a/src/res_comp.c
 +++ b/src/res_comp.c
  OBJECTS = $(SOURCES:.c=.o) version.o
 --- a/src/res_comp.c
 +++ b/src/res_comp.c
-@@ -231,7 +231,7 @@
+@@ -229,7 +229,7 @@ dn_skipname(u_char *comp_dn, u_char *eom
   * the first name on the list, not the pointer to the start of the
   * message.
   */
   * the first name on the list, not the pointer to the start of the
   * message.
   */
                  u_char **lastdnptr)
  {
      u_char *dn, *cp, **cpp;
                  u_char **lastdnptr)
  {
      u_char *dn, *cp, **cpp;
---- a/zlib/Makefile.in
-+++ b/zlib/Makefile.in
-@@ -69,7 +69,7 @@
- build: libz.a
- libz.a: $(OBJS) $(OBJA)
--      $(AR) $@ $(OBJS) $(OBJA)
-+      $(AR) rcv $@ $(OBJS) $(OBJA)
-       -@ ($(RANLIB) $@ || true) >/dev/null 2>&1
- match.o: match.S
index 5bdcc1de5625407019f0c91af1f2dfcf4dca7d17..400caede641fb94af3e856c91f7ec752577de4a5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/resolv.h
 +++ b/include/resolv.h
 --- a/include/resolv.h
 +++ b/include/resolv.h
-@@ -62,7 +62,7 @@
+@@ -60,7 +60,7 @@
  #if ((__GNU_LIBRARY__ == 6) && (__GLIBC__ >= 2) && (__GLIBC_MINOR__ >= 3))
  # define MAXRESOLVSORT                10      /* number of net to sort on */
  
  #if ((__GNU_LIBRARY__ == 6) && (__GLIBC__ >= 2) && (__GLIBC_MINOR__ >= 3))
  # define MAXRESOLVSORT                10      /* number of net to sort on */
  
@@ -9,7 +9,7 @@
        int     retrans;                /* retransmition time interval */
        int     retry;                  /* number of times to retransmit */
        u_long  options;                /* option flags - see below. */
        int     retrans;                /* retransmition time interval */
        int     retry;                  /* number of times to retransmit */
        u_long  options;                /* option flags - see below. */
-@@ -81,12 +81,9 @@
+@@ -79,12 +79,9 @@ struct __res_state {
                struct in_addr  addr;
                u_int32_t       mask;
        } sort_list[MAXRESOLVSORT];
                struct in_addr  addr;
                u_int32_t       mask;
        } sort_list[MAXRESOLVSORT];
@@ -23,7 +23,7 @@
  
  #else
  
  
  #else
  
-@@ -103,9 +100,10 @@
+@@ -101,9 +98,10 @@ struct state {
      unsigned short order[MAXSERVICES + 1];    /* search service order */
  };
  
      unsigned short order[MAXSERVICES + 1];    /* search service order */
  };