brcm47xx: add support for Netgear WGR614 V10
authorRafał Miłecki <zajec5@gmail.com>
Thu, 20 Nov 2014 22:15:21 +0000 (22:15 +0000)
committerRafał Miłecki <zajec5@gmail.com>
Thu, 20 Nov 2014 22:15:21 +0000 (22:15 +0000)
Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
SVN-Revision: 43336

target/linux/brcm47xx/image/Makefile
target/linux/brcm47xx/patches-3.14/320-MIPS-BCM47XX-Devices-database-update-for-3.x.patch [new file with mode: 0644]
target/linux/brcm47xx/patches-3.14/800-bcma-add-table-of-serial-flashes-with-smaller-blocks.patch [new file with mode: 0644]
target/linux/brcm47xx/patches-3.18/320-MIPS-BCM47XX-Devices-database-update-for-3.x.patch [new file with mode: 0644]
target/linux/brcm47xx/patches-3.18/800-bcma-add-table-of-serial-flashes-with-smaller-blocks.patch [new file with mode: 0644]

index 33a3c854efa0ef6e85fe445695969e19f651a70e..774a3d6cdb3152d65846135076212fb48aa32c52 100644 (file)
@@ -181,6 +181,8 @@ endef
 #################################################
 
 define Image/Build/mips74k/devices-with-64k-blocks
+       $(call Image/Build/Chk,$(1),wgr614_v10_north_america,U12H139T01_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
+       $(call Image/Build/Chk,$(1),wgr614_v10_other_regions,U12H139T01_NETGEAR,1,$(patsubst jffs2-%,jffs2,$(1)))
        $(call Image/Build/Chk,$(1),wndr3400_v1,U12H155T00_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
        $(call Image/Build/Chk,$(1),wndr3400_v2,U12H187T00_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
        $(call Image/Build/Chk,$(1),wndr3700_v3,U12H194T00_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
diff --git a/target/linux/brcm47xx/patches-3.14/320-MIPS-BCM47XX-Devices-database-update-for-3.x.patch b/target/linux/brcm47xx/patches-3.14/320-MIPS-BCM47XX-Devices-database-update-for-3.x.patch
new file mode 100644 (file)
index 0000000..1522a16
--- /dev/null
@@ -0,0 +1,41 @@
+From be64eb65a1b24ea9528b0fcdd652ee2068da6106 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
+Date: Thu, 20 Nov 2014 20:56:27 +0100
+Subject: [PATCH] MIPS: BCM47XX: Devices database update for 3.x
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+---
+ arch/mips/bcm47xx/board.c                          | 1 +
+ arch/mips/include/asm/mach-bcm47xx/bcm47xx_board.h | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/arch/mips/bcm47xx/board.c b/arch/mips/bcm47xx/board.c
+index e2cc84a..47294a8 100644
+--- a/arch/mips/bcm47xx/board.c
++++ b/arch/mips/bcm47xx/board.c
+@@ -165,6 +165,7 @@ static const
+ struct bcm47xx_board_type_list1 bcm47xx_board_list_board_id[] __initconst = {
+       {{BCM47XX_BOARD_NETGEAR_WGR614V8, "Netgear WGR614 V8"}, "U12H072T00_NETGEAR"},
+       {{BCM47XX_BOARD_NETGEAR_WGR614V9, "Netgear WGR614 V9"}, "U12H094T00_NETGEAR"},
++      {{BCM47XX_BOARD_NETGEAR_WGR614_V10, "Netgear WGR614 V10"}, "U12H139T01_NETGEAR"},
+       {{BCM47XX_BOARD_NETGEAR_WNDR3300, "Netgear WNDR3300"}, "U12H093T00_NETGEAR"},
+       {{BCM47XX_BOARD_NETGEAR_WNDR3400V1, "Netgear WNDR3400 V1"}, "U12H155T00_NETGEAR"},
+       {{BCM47XX_BOARD_NETGEAR_WNDR3400V2, "Netgear WNDR3400 V2"}, "U12H187T00_NETGEAR"},
+diff --git a/arch/mips/include/asm/mach-bcm47xx/bcm47xx_board.h b/arch/mips/include/asm/mach-bcm47xx/bcm47xx_board.h
+index 1f5643b..4211dd9 100644
+--- a/arch/mips/include/asm/mach-bcm47xx/bcm47xx_board.h
++++ b/arch/mips/include/asm/mach-bcm47xx/bcm47xx_board.h
+@@ -86,6 +86,7 @@ enum bcm47xx_board {
+       BCM47XX_BOARD_NETGEAR_WGR614V8,
+       BCM47XX_BOARD_NETGEAR_WGR614V9,
++      BCM47XX_BOARD_NETGEAR_WGR614_V10,
+       BCM47XX_BOARD_NETGEAR_WNDR3300,
+       BCM47XX_BOARD_NETGEAR_WNDR3400V1,
+       BCM47XX_BOARD_NETGEAR_WNDR3400V2,
+-- 
+1.8.4.5
+
diff --git a/target/linux/brcm47xx/patches-3.14/800-bcma-add-table-of-serial-flashes-with-smaller-blocks.patch b/target/linux/brcm47xx/patches-3.14/800-bcma-add-table-of-serial-flashes-with-smaller-blocks.patch
new file mode 100644 (file)
index 0000000..7a602b7
--- /dev/null
@@ -0,0 +1,77 @@
+From 597715c61ae75a05ab3310a34ff3857a006f0f63 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
+Date: Thu, 20 Nov 2014 21:32:42 +0100
+Subject: [PATCH] bcma: add table of serial flashes with smaller blocks
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+---
+ drivers/bcma/driver_chipcommon_sflash.c | 29 +++++++++++++++++++++++++++++
+ 1 file changed, 29 insertions(+)
+
+diff --git a/drivers/bcma/driver_chipcommon_sflash.c b/drivers/bcma/driver_chipcommon_sflash.c
+index 7e11ef4..25d9e17 100644
+--- a/drivers/bcma/driver_chipcommon_sflash.c
++++ b/drivers/bcma/driver_chipcommon_sflash.c
+@@ -9,6 +9,7 @@
+ #include <linux/platform_device.h>
+ #include <linux/bcma/bcma.h>
++#include <bcm47xx_board.h>
+ static struct resource bcma_sflash_resource = {
+       .name   = "bcma_sflash",
+@@ -41,6 +42,13 @@ static const struct bcma_sflash_tbl_e bcma_sflash_st_tbl[] = {
+       { NULL },
+ };
++/* Some devices use smaller blocks (and have more of them) */
++static const struct bcma_sflash_tbl_e bcma_sflash_st_shrink_tbl[] = {
++      { "M25P16", 0x14, 0x1000, 512, },
++      { "M25P32", 0x15, 0x1000, 1024, },
++      { NULL },
++};
++
+ static const struct bcma_sflash_tbl_e bcma_sflash_sst_tbl[] = {
+       { "SST25WF512", 1, 0x1000, 16, },
+       { "SST25VF512", 0x48, 0x1000, 16, },
+@@ -84,6 +92,23 @@ static void bcma_sflash_cmd(struct bcma_drv_cc *cc, u32 opcode)
+       bcma_err(cc->core->bus, "SFLASH control command failed (timeout)!\n");
+ }
++const struct bcma_sflash_tbl_e *bcma_sflash_shrink_flash(u32 id)
++{
++      enum bcm47xx_board board = bcm47xx_board_get();
++      const struct bcma_sflash_tbl_e *e;
++
++      switch (board) {
++      case BCM47XX_BOARD_NETGEAR_WGR614_V10:
++              for (e = bcma_sflash_st_shrink_tbl; e->name; e++) {
++                      if (e->id == id)
++                              return e;
++              }
++              return NULL;
++      default:
++              return NULL;
++      }
++}
++
+ /* Initialize serial flash access */
+ int bcma_sflash_init(struct bcma_drv_cc *cc)
+ {
+@@ -114,6 +139,10 @@ int bcma_sflash_init(struct bcma_drv_cc *cc)
+               case 0x13:
+                       return -ENOTSUPP;
+               default:
++                      e = bcma_sflash_shrink_flash(id);
++                      if (e)
++                              break;
++
+                       for (e = bcma_sflash_st_tbl; e->name; e++) {
+                               if (e->id == id)
+                                       break;
+-- 
+1.8.4.5
+
diff --git a/target/linux/brcm47xx/patches-3.18/320-MIPS-BCM47XX-Devices-database-update-for-3.x.patch b/target/linux/brcm47xx/patches-3.18/320-MIPS-BCM47XX-Devices-database-update-for-3.x.patch
new file mode 100644 (file)
index 0000000..1522a16
--- /dev/null
@@ -0,0 +1,41 @@
+From be64eb65a1b24ea9528b0fcdd652ee2068da6106 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
+Date: Thu, 20 Nov 2014 20:56:27 +0100
+Subject: [PATCH] MIPS: BCM47XX: Devices database update for 3.x
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+---
+ arch/mips/bcm47xx/board.c                          | 1 +
+ arch/mips/include/asm/mach-bcm47xx/bcm47xx_board.h | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/arch/mips/bcm47xx/board.c b/arch/mips/bcm47xx/board.c
+index e2cc84a..47294a8 100644
+--- a/arch/mips/bcm47xx/board.c
++++ b/arch/mips/bcm47xx/board.c
+@@ -165,6 +165,7 @@ static const
+ struct bcm47xx_board_type_list1 bcm47xx_board_list_board_id[] __initconst = {
+       {{BCM47XX_BOARD_NETGEAR_WGR614V8, "Netgear WGR614 V8"}, "U12H072T00_NETGEAR"},
+       {{BCM47XX_BOARD_NETGEAR_WGR614V9, "Netgear WGR614 V9"}, "U12H094T00_NETGEAR"},
++      {{BCM47XX_BOARD_NETGEAR_WGR614_V10, "Netgear WGR614 V10"}, "U12H139T01_NETGEAR"},
+       {{BCM47XX_BOARD_NETGEAR_WNDR3300, "Netgear WNDR3300"}, "U12H093T00_NETGEAR"},
+       {{BCM47XX_BOARD_NETGEAR_WNDR3400V1, "Netgear WNDR3400 V1"}, "U12H155T00_NETGEAR"},
+       {{BCM47XX_BOARD_NETGEAR_WNDR3400V2, "Netgear WNDR3400 V2"}, "U12H187T00_NETGEAR"},
+diff --git a/arch/mips/include/asm/mach-bcm47xx/bcm47xx_board.h b/arch/mips/include/asm/mach-bcm47xx/bcm47xx_board.h
+index 1f5643b..4211dd9 100644
+--- a/arch/mips/include/asm/mach-bcm47xx/bcm47xx_board.h
++++ b/arch/mips/include/asm/mach-bcm47xx/bcm47xx_board.h
+@@ -86,6 +86,7 @@ enum bcm47xx_board {
+       BCM47XX_BOARD_NETGEAR_WGR614V8,
+       BCM47XX_BOARD_NETGEAR_WGR614V9,
++      BCM47XX_BOARD_NETGEAR_WGR614_V10,
+       BCM47XX_BOARD_NETGEAR_WNDR3300,
+       BCM47XX_BOARD_NETGEAR_WNDR3400V1,
+       BCM47XX_BOARD_NETGEAR_WNDR3400V2,
+-- 
+1.8.4.5
+
diff --git a/target/linux/brcm47xx/patches-3.18/800-bcma-add-table-of-serial-flashes-with-smaller-blocks.patch b/target/linux/brcm47xx/patches-3.18/800-bcma-add-table-of-serial-flashes-with-smaller-blocks.patch
new file mode 100644 (file)
index 0000000..7a602b7
--- /dev/null
@@ -0,0 +1,77 @@
+From 597715c61ae75a05ab3310a34ff3857a006f0f63 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
+Date: Thu, 20 Nov 2014 21:32:42 +0100
+Subject: [PATCH] bcma: add table of serial flashes with smaller blocks
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+---
+ drivers/bcma/driver_chipcommon_sflash.c | 29 +++++++++++++++++++++++++++++
+ 1 file changed, 29 insertions(+)
+
+diff --git a/drivers/bcma/driver_chipcommon_sflash.c b/drivers/bcma/driver_chipcommon_sflash.c
+index 7e11ef4..25d9e17 100644
+--- a/drivers/bcma/driver_chipcommon_sflash.c
++++ b/drivers/bcma/driver_chipcommon_sflash.c
+@@ -9,6 +9,7 @@
+ #include <linux/platform_device.h>
+ #include <linux/bcma/bcma.h>
++#include <bcm47xx_board.h>
+ static struct resource bcma_sflash_resource = {
+       .name   = "bcma_sflash",
+@@ -41,6 +42,13 @@ static const struct bcma_sflash_tbl_e bcma_sflash_st_tbl[] = {
+       { NULL },
+ };
++/* Some devices use smaller blocks (and have more of them) */
++static const struct bcma_sflash_tbl_e bcma_sflash_st_shrink_tbl[] = {
++      { "M25P16", 0x14, 0x1000, 512, },
++      { "M25P32", 0x15, 0x1000, 1024, },
++      { NULL },
++};
++
+ static const struct bcma_sflash_tbl_e bcma_sflash_sst_tbl[] = {
+       { "SST25WF512", 1, 0x1000, 16, },
+       { "SST25VF512", 0x48, 0x1000, 16, },
+@@ -84,6 +92,23 @@ static void bcma_sflash_cmd(struct bcma_drv_cc *cc, u32 opcode)
+       bcma_err(cc->core->bus, "SFLASH control command failed (timeout)!\n");
+ }
++const struct bcma_sflash_tbl_e *bcma_sflash_shrink_flash(u32 id)
++{
++      enum bcm47xx_board board = bcm47xx_board_get();
++      const struct bcma_sflash_tbl_e *e;
++
++      switch (board) {
++      case BCM47XX_BOARD_NETGEAR_WGR614_V10:
++              for (e = bcma_sflash_st_shrink_tbl; e->name; e++) {
++                      if (e->id == id)
++                              return e;
++              }
++              return NULL;
++      default:
++              return NULL;
++      }
++}
++
+ /* Initialize serial flash access */
+ int bcma_sflash_init(struct bcma_drv_cc *cc)
+ {
+@@ -114,6 +139,10 @@ int bcma_sflash_init(struct bcma_drv_cc *cc)
+               case 0x13:
+                       return -ENOTSUPP;
+               default:
++                      e = bcma_sflash_shrink_flash(id);
++                      if (e)
++                              break;
++
+                       for (e = bcma_sflash_st_tbl; e->name; e++) {
+                               if (e->id == id)
+                                       break;
+-- 
+1.8.4.5
+