Upgrade dropbear to 0.50 (#2201)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 11 Aug 2007 21:53:15 +0000 (21:53 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 11 Aug 2007 21:53:15 +0000 (21:53 +0000)
SVN-Revision: 8400

package/dropbear/Makefile
package/dropbear/patches/100-pubkey_path.patch
package/dropbear/patches/110-change_user.patch
package/dropbear/patches/120-hostkey_prompt.patch
package/dropbear/patches/130-ssh_ignore_o_and_x_args.patch
package/dropbear/patches/140-use_dev_urandom.patch
package/dropbear/patches/150-dbconvert_standalone.patch
package/dropbear/patches/160-tty_close.patch

index 60625947af3a9d5e0afe14c46a8059905191bf0c..c4816f116d0c6294a584980ca008a8116a32acb3 100644 (file)
@@ -9,13 +9,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dropbear
-PKG_VERSION:=0.49
-PKG_RELEASE:=2
+PKG_VERSION:=0.50
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://matt.ucc.asn.au/dropbear/releases/ \
-                               http://www.mirrors.wiretapped.net/security/cryptography/apps/ssh/dropbear/
-PKG_MD5SUM:=7b20c85f1ee34f018a1b948eae003df9
+       http://www.mirrors.wiretapped.net/security/cryptography/apps/ssh/dropbear/
+PKG_MD5SUM:=5c0f7405b915799c3d952d3a93a5df69
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -75,8 +75,7 @@ endef
        
 define Package/dropbear/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dropbearmulti \
-               $(1)/usr/sbin/dropbear
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dropbearmulti $(1)/usr/sbin/dropbear
        $(INSTALL_DIR) $(1)/usr/bin
        ln -sf ../sbin/dropbear $(1)/usr/bin/scp
        ln -sf ../sbin/dropbear $(1)/usr/bin/ssh
@@ -93,8 +92,7 @@ endef
 
 define Package/dropbearconvert/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dropbearconvert \
-               $(1)/usr/bin/dropbearconvert
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dropbearconvert $(1)/usr/bin/dropbearconvert
 endef
 
 $(eval $(call BuildPackage,dropbear))
index 3f76e3a743913e52a010a43c6da3ac1c6bcaf2f5..9c7fc19c4315dcca22876919323151c429e33490 100644 (file)
@@ -1,7 +1,7 @@
-Index: dropbear-0.49/svr-authpubkey.c
+Index: dropbear-0.50/svr-authpubkey.c
 ===================================================================
---- dropbear-0.49.orig/svr-authpubkey.c        2007-06-04 13:21:39.475975408 +0200
-+++ dropbear-0.49/svr-authpubkey.c     2007-06-04 13:21:39.542965224 +0200
+--- dropbear-0.50.orig/svr-authpubkey.c        2007-08-10 23:47:48.000000000 +0200
++++ dropbear-0.50/svr-authpubkey.c     2007-08-10 23:47:48.000000000 +0200
 @@ -176,6 +176,8 @@
                goto out;
        }
index 9a9a6afda14ad89c27f130c4385bce9d695c08e2..20bb41c2d2ae3fcc49d1f94dcda6811d11273a6d 100644 (file)
@@ -1,7 +1,7 @@
-Index: dropbear-0.49/svr-chansession.c
+Index: dropbear-0.50/svr-chansession.c
 ===================================================================
---- dropbear-0.49.orig/svr-chansession.c       2007-06-04 13:21:39.455978448 +0200
-+++ dropbear-0.49/svr-chansession.c    2007-06-04 13:21:39.751933456 +0200
+--- dropbear-0.50.orig/svr-chansession.c       2007-08-10 23:47:48.000000000 +0200
++++ dropbear-0.50/svr-chansession.c    2007-08-10 23:47:48.000000000 +0200
 @@ -908,12 +908,12 @@
        /* We can only change uid/gid as root ... */
        if (getuid() == 0) {
index 3a34771bed317273474ae46f4450473550238315..e69de29bb2d1d6434b8b29ae775ad8c2e48c5391 100644 (file)
@@ -1,13 +0,0 @@
-Index: dropbear-0.49/cli-kex.c
-===================================================================
---- dropbear-0.49.orig/cli-kex.c       2007-06-04 13:21:39.435981488 +0200
-+++ dropbear-0.49/cli-kex.c    2007-06-04 13:21:39.937905184 +0200
-@@ -126,7 +126,7 @@
-               m_free(fp);
-               return;
-       }
--      fprintf(stderr, "\nHost '%s' is not in the trusted hosts file.\n(fingerprint %s)\nDo you want to continue connecting? (y/n)\n", 
-+      fprintf(stderr, "\nHost '%s' is not in the trusted hosts file.\n(fingerprint %s)\nDo you want to continue connecting? (y/n)", 
-                       cli_opts.remotehost, 
-                       fp);
-       m_free(fp);
index b8a7d44e81f4613e62e80d8189307cc7337f2f01..26b5b7f23767d3a3af87a291682068212a210052 100644 (file)
@@ -1,8 +1,8 @@
-Index: dropbear-0.49/cli-runopts.c
+Index: dropbear-0.50/cli-runopts.c
 ===================================================================
---- dropbear-0.49.orig/cli-runopts.c   2007-06-04 13:21:39.414984680 +0200
-+++ dropbear-0.49/cli-runopts.c        2007-06-04 13:21:40.122877064 +0200
-@@ -203,6 +203,10 @@
+--- dropbear-0.50.orig/cli-runopts.c   2007-08-10 23:47:47.000000000 +0200
++++ dropbear-0.50/cli-runopts.c        2007-08-10 23:47:49.000000000 +0200
+@@ -219,6 +219,10 @@
                                        debug_trace = 1;
                                        break;
  #endif
@@ -13,7 +13,7 @@ Index: dropbear-0.49/cli-runopts.c
                                case 'F':
                                case 'e':
                                case 'c':
-@@ -214,7 +218,6 @@
+@@ -230,7 +234,6 @@
  #ifndef ENABLE_CLI_LOCALTCPFWD
                                case 'L':
  #endif
index 61deff8540fd05015377e200d79985152193d535..e69de29bb2d1d6434b8b29ae775ad8c2e48c5391 100644 (file)
@@ -1,13 +0,0 @@
-Index: dropbear-0.49/options.h
-===================================================================
---- dropbear-0.49.orig/options.h       2007-06-04 13:21:39.394987720 +0200
-+++ dropbear-0.49/options.h    2007-06-04 13:21:40.305849248 +0200
-@@ -159,7 +159,7 @@
-  * however significantly reduce the security of your ssh connections
-  * if the PRNG state becomes guessable - make sure you know what you are
-  * doing if you change this. */
--#define DROPBEAR_RANDOM_DEV "/dev/random"
-+#define DROPBEAR_RANDOM_DEV "/dev/urandom"
- /* prngd must be manually set up to produce output */
- /*#define DROPBEAR_PRNGD_SOCKET "/var/run/dropbear-rng"*/
index d8e283e4de85cb82e117b9021de53bf282dd3237..54d74d3ac541480f0e4cb12b99a5477c49bf14e2 100644 (file)
@@ -1,7 +1,7 @@
-Index: dropbear-0.49/options.h
+Index: dropbear-0.50/options.h
 ===================================================================
---- dropbear-0.49.orig/options.h       2007-06-04 13:21:40.305849248 +0200
-+++ dropbear-0.49/options.h    2007-06-04 13:21:40.493820672 +0200
+--- dropbear-0.50.orig/options.h       2007-08-10 23:47:47.000000000 +0200
++++ dropbear-0.50/options.h    2007-08-10 23:47:49.000000000 +0200
 @@ -5,6 +5,11 @@
  #ifndef _OPTIONS_H_
  #define _OPTIONS_H_
index 0fd9ef684d60bf5ba67f3096cf7189b150038e6d..8c06e0f912ced80494c92dae53e1888a3285e6cb 100644 (file)
@@ -1,8 +1,8 @@
-Index: dropbear-0.49/common-channel.c
+Index: dropbear-0.50/common-channel.c
 ===================================================================
---- dropbear-0.49.orig/common-channel.c        2007-06-04 13:21:39.354993800 +0200
-+++ dropbear-0.49/common-channel.c     2007-06-04 13:21:40.676792856 +0200
-@@ -310,10 +310,10 @@
+--- dropbear-0.50.orig/common-channel.c        2007-08-10 23:47:47.000000000 +0200
++++ dropbear-0.50/common-channel.c     2007-08-10 23:47:50.000000000 +0200
+@@ -311,10 +311,10 @@
                send_msg_channel_eof(channel);
        }