[package] do not link bmxd statically (#5501)
authorFlorian Fainelli <florian@openwrt.org>
Tue, 14 Jul 2009 00:28:24 +0000 (00:28 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 14 Jul 2009 00:28:24 +0000 (00:28 +0000)
SVN-Revision: 16834

net/bmxd/patches/001-makefile-fix.patch

index 2c47db43bac07fbcfbf518c809cc0e181bb63828..cf18493bbb1e10c633f7f79ebf70f48b70723460 100644 (file)
@@ -1,6 +1,6 @@
-diff -urb bmxd-r1042.orig/Makefile bmxd-r1042/Makefile
---- bmxd-r1042.orig/Makefile   2008-05-08 00:07:50.000000000 +0200
-+++ bmxd-r1042/Makefile        2008-05-08 00:07:16.000000000 +0200
+diff -urN bmxd-r1075/Makefile bmxd-r1075.new/Makefile
+--- bmxd-r1075/Makefile        2008-08-04 20:10:56.000000000 +0200
++++ bmxd-r1075.new/Makefile    2009-07-14 02:28:16.000000000 +0200
 @@ -19,11 +19,15 @@
  
  # CC =                gcc
@@ -15,7 +15,14 @@ diff -urb bmxd-r1042.orig/Makefile bmxd-r1042/Makefile
 -LDFLAGS =     -lpthread -static -g -pg
 +# JoW: "-pg" results in "gcrt1.o: No such file" ?!
 +#LDFLAGS =    -lpthread -static -g -pg
-+LDFLAGS =     -lpthread -static -g
++LDFLAGS =     -lpthread -g
  
  
  #STRIP=                       strip
+@@ -80,4 +84,4 @@
+               rm -f $(BINARY_NAME) *.o
+ clean-all:
+-              rm -rf $(PACKAGE_NAME)_* dl/*
+\ No newline at end of file
++              rm -rf $(PACKAGE_NAME)_* dl/*