[backfire] merge r20669
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 3 Apr 2010 13:44:38 +0000 (13:44 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 3 Apr 2010 13:44:38 +0000 (13:44 +0000)
SVN-Revision: 20671

package/base-files/Makefile
package/base-files/files/etc/init.d/network

index 856340f667b925eb598e8afa136451f79cb2de29..b4942d938cb8747c0c9428453062c9009305e99d 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=41
+PKG_RELEASE:=42
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
index 3587c24aaa87e50cd46ab158f39c9e2f99d5e6c9..43d0a842322b51e8eed9b3676d4d4da6b1702d44 100755 (executable)
@@ -9,9 +9,12 @@ boot() {
 
        include /lib/network
        setup_switch
-       [ -s /etc/config/wireless ] || \
+       grep -qs config /etc/config/wireless && {
+               /sbin/wifi up
+       } || {
+               rm -f /etc/config/wireless
                /sbin/wifi detect > /etc/config/wireless
-       /sbin/wifi up
+       }
 }
 
 start() {