[package] add libvncserver (#5093)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 17 May 2009 15:42:30 +0000 (15:42 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 17 May 2009 15:42:30 +0000 (15:42 +0000)
SVN-Revision: 15894

libs/libvncserver/Makefile [new file with mode: 0644]
libs/libvncserver/patches/100-noexamples.patch [new file with mode: 0644]

diff --git a/libs/libvncserver/Makefile b/libs/libvncserver/Makefile
new file mode 100644 (file)
index 0000000..931ae7f
--- /dev/null
@@ -0,0 +1,57 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=LibVNCServer
+PKG_VERSION:=0.9.7
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/libvncserver
+PKG_MD5SUM:=14af5bdae461df4666c18e5f83c150c4
+PKG_FIXUP:=libtool
+
+include $(INCLUDE_DIR)/package.mk
+
+PKG_INSTALL=1
+
+define Package/libvncserver
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=+zlib +libiconv
+  TITLE:=VNC Server Library
+endef
+
+CONFIGURE_ARGS += \
+       --without-xkeyboard \
+       --without-xinerama \
+       --without-xrandr \
+       --without-xfixes \
+       --without-xdamage \
+       --without-xtrap \
+       --without-xrecord \
+       --without-fbpm \
+       --without-dpms \
+       --without-filetransfer \
+       --without-macosx-native \
+       --without-ssl \
+       --without-avahi
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/{lib,include,bin}
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib* $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+endef
+
+define Package/libvncserver/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libvncserver))
diff --git a/libs/libvncserver/patches/100-noexamples.patch b/libs/libvncserver/patches/100-noexamples.patch
new file mode 100644 (file)
index 0000000..6e3cbb2
--- /dev/null
@@ -0,0 +1,13 @@
+--- LibVNCServer-0.9.7/Makefile.in.orig        2009-01-12 03:53:15.000000000 +0100
++++ LibVNCServer-0.9.7/Makefile.in     2009-05-02 00:23:00.000000000 +0200
+@@ -228,8 +228,8 @@
+ target_alias = @target_alias@
+ with_ffmpeg = @with_ffmpeg@
+ @WITH_X11VNC_TRUE@X11VNC = x11vnc
+-SUBDIRS = libvncserver examples contrib libvncclient vncterm classes client_examples test $(X11VNC)
+-DIST_SUBDIRS = libvncserver examples contrib libvncclient vncterm classes client_examples test
++SUBDIRS = libvncserver
++DIST_SUBDIRS = libvncserver
+ bin_SCRIPTS = libvncserver-config
+ #include_HEADERS=rfb.h rfbconfig.h rfbint.h rfbproto.h keysym.h rfbregion.h
+ include_HEADERS = rfb/rfb.h rfb/rfbconfig.h rfb/rfbint.h rfb/rfbproto.h \