add libXft
authorFelix Fietkau <nbd@openwrt.org>
Fri, 25 Jan 2008 11:23:41 +0000 (11:23 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 25 Jan 2008 11:23:41 +0000 (11:23 +0000)
SVN-Revision: 10247

XOrg/lib/libXft/Makefile [new file with mode: 0644]

diff --git a/XOrg/lib/libXft/Makefile b/XOrg/lib/libXft/Makefile
new file mode 100644 (file)
index 0000000..7e8d2eb
--- /dev/null
@@ -0,0 +1,48 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# blogic@openwrt.org 
+include $(TOPDIR)/rules.mk
+
+PKG_BASE_NAME:=libXft
+PKG_NAME:=libXft
+PKG_RELEASE:=1
+PKG_VERSION:=X11R7.2-2.1.12
+PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.2/src/lib/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}-$(PKG_VERSION)/
+
+PKG_FIXUP=libtool
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libXft
+  SECTION:=xorg-libraries
+  CATEGORY:=Xorg
+  SUBMENU:=libraries
+  DEPENDS:=+xorg-headers-native +util-macros +fontconfig +libSM @DISPLAY_SUPPORT
+  TITLE:=libXft
+  URL:=http://xorg.freedesktop.org/
+endef
+
+define Build/Compile
+       $(call $(PKG_NAME)/Compile)
+       make -C $(PKG_BUILD_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       DESTDIR=$(PKG_INSTALL_DIR) $(MAKE) -C $(PKG_BUILD_DIR) $(MAKE_FLAGS) install
+endef
+
+define Package/libXft/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       find $(PKG_INSTALL_DIR)/usr/lib/ -name lib*so* | $(XARGS) -I % -t cp -P % $(1)/usr/lib 
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+endef
+
+$(eval $(call BuildPackage,libXft))