Add different Wi-Fi profiles
authorFlorian Fainelli <florian@openwrt.org>
Mon, 11 Dec 2006 17:55:39 +0000 (17:55 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 11 Dec 2006 17:55:39 +0000 (17:55 +0000)
SVN-Revision: 5761

target/linux/au1000-2.6/Makefile

index 258990f8b76eb9fa4a0a2d54b89e84ef1f16e15c..45b718135d6127c4f78aeb2641d930cb7526cc7f 100644 (file)
@@ -28,5 +28,23 @@ define Kernel/BuildImage
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
 endef
 
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
 endef
 
+define Profile/Atheros
+  NAME:=Atheros WiFi (default)
+  PACKAGES:=kmod-madwifi
+endef
+$(eval $(call Profile,Atheros))
+
+define Profile/Intel
+  NAME:=Intel IPW2200 WiFi
+  PACKAGES:=kmod-net-ipw2200
+endef
+$(eval $(call Profile,Intel))
+
+define Profile/Broadcom
+  NAME:=Broadcom BCM43xx WiFi
+  PACKAGES:=kmod-net-bcm43xx
+endef
+$(eval $(call Profile,Broadcom))
+
 $(eval $(call BuildKernel))
 
 $(eval $(call BuildKernel))