Update netpipe to 3.7.1 (#3637)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 6 Jul 2008 12:02:42 +0000 (12:02 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 6 Jul 2008 12:02:42 +0000 (12:02 +0000)
SVN-Revision: 11696

net/netpipe/Makefile

index b3df930ead61c25848bb3b3f8e33283361e1e660..ea59bb27e3024917b1c0b754a794eebb0d9a9553 100644 (file)
@@ -9,14 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netpipe
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netpipe
-PKG_VERSION:=3.6.2
+PKG_VERSION:=3.7.1
 PKG_RELEASE:=1
 
 PKG_RELEASE:=1
 
-PKG_SOURCE:=NetPIPE_$(PKG_VERSION).tar.gz
+PKG_SOURCE:=NetPIPE-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.scl.ameslab.gov/netpipe/code
 PKG_SOURCE_URL:=http://www.scl.ameslab.gov/netpipe/code
-PKG_MD5SUM:=62570140a3617eca4b15b3255d3edbe6
+PKG_MD5SUM:=cc458a9154f6b8c6da9fae16627beec4
 
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/NetPIPE_$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/NetPIPE-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,7 +28,15 @@ define Package/netpipe
 endef
 
 define Package/netpipe/description
 endef
 
 define Package/netpipe/description
-A Network Protocol Independent Performance Evaluator
+       NetPIPE is a protocol independent performance tool that visually
+       represents the network performance under a variety of conditions. It
+       performs simple ping-pong tests, bouncing messages of increasing size
+       between two processes, whether across a network or within an SMP
+       system. Message sizes are chosen at regular intervals, and with slight
+       perturbations, to provide a complete test of the communication system.
+       Each data point involves many ping-pong tests to provide an accurate
+       timing. Latencies are calculated by dividing the round trip time in
+       half for small messages ( < 64 Bytes ).
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure