[packages] wide-dhcpv6: now that hexdump works again, fix endianess detection (#10396)
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 15 Nov 2011 17:41:50 +0000 (17:41 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 15 Nov 2011 17:41:50 +0000 (17:41 +0000)
SVN-Revision: 29157

ipv6/wide-dhcpv6/Makefile
ipv6/wide-dhcpv6/files/dhcp6c.init

index 9a869b3327f2a6dc104aef06f44910fae359fd4d..5971312fc91b5d964c0ec8d0177623bc5336d333 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wide-dhcpv6
 PKG_VERSION:=20080615
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
index e272001882010651c7b4938fe05dce42904a5c45..b60b45b0e31cba5a08375549f46b9cedf33e740d 100644 (file)
@@ -33,7 +33,7 @@ dhcp6c_write_duid() {
                        local oIFS="$IFS"; IFS=":"; set -- $mac; IFS="$oIFS"
 
                        # low endian
-                       if [ "$(printf \\1 | hexdump -n1 -ve '8/2 "%04x"')" = "0001" ]; then
+                       if [ "$(printf \\1 | hexdump -n1 -ve '8/2 "" "%04x" ""')" = "0001" ]; then
                                printf \\x0a\\x00
 
                        # big endian