batman: cleanup to match advanced version
authorTim Yardley <lst@openwrt.org>
Tue, 31 Jul 2007 22:08:27 +0000 (22:08 +0000)
committerTim Yardley <lst@openwrt.org>
Tue, 31 Jul 2007 22:08:27 +0000 (22:08 +0000)
SVN-Revision: 8290

net/batman/Makefile

index b35f6e4883614a338c18dde8982e2db35e928d04..9c9c41c14c0ae76f81919973960e6b456712d0b0 100644 (file)
@@ -45,11 +45,10 @@ MAKE_FLAGS += \
        batmand install
 
 define Package/batman/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/batmand $(1)/usr/sbin/
-       $(CP) -a ./files/* $(1)/
-       chmod -R 755 $(1)/etc/init.d/batman
+       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/config $(1)/etc/init.d
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/batmand $(1)/usr/sbin/
+       $(INSTALL_BIN) ./files/etc/init.d/batman $(1)/etc/init.d
+       $(INSTALL_DATA) ./files/etc/config/batman $(1)/etc/config
 endef
 
-
 $(eval $(call BuildPackage,batman))