fix segfault and set right dependency
authorJens Muecke <jens@nons.de>
Fri, 3 Aug 2007 03:08:18 +0000 (03:08 +0000)
committerJens Muecke <jens@nons.de>
Fri, 3 Aug 2007 03:08:18 +0000 (03:08 +0000)
SVN-Revision: 8326

net/olsrd/Makefile
net/olsrd/patches/110-cflags.patch [new file with mode: 0644]

index a64bfffb3b4a9fe1a3e56f6cba7021fee8123a8c..3c7581b71e612b4914e465f2d1c0b3df8cb3747c 100644 (file)
@@ -43,14 +43,14 @@ endef
 
 define Package/olsrd-mod-bmf
   $(call Package/olsrd)
-  DEPENDS:=olsrd libpthread kmod-tun
+  DEPENDS:=olsrd +libpthread +kmod-tun
   TITLE:=Basic multicast forwarding plugin
   MENU:=0
 endef
 
 define Package/olsrd-mod-dyn-gw
   $(call Package/olsrd)
-  DEPENDS:=olsrd
+  DEPENDS:=olsrd +libpthread
   TITLE:=Dynamic internet gateway plugin
   MENU:=0
 endef
diff --git a/net/olsrd/patches/110-cflags.patch b/net/olsrd/patches/110-cflags.patch
new file mode 100644 (file)
index 0000000..b403f67
--- /dev/null
@@ -0,0 +1,22 @@
+Index: olsrd-0.5.2/Makefile.inc
+===================================================================
+--- olsrd-0.5.2.orig/Makefile.inc      2007-08-03 04:25:53.320043315 +0200
++++ olsrd-0.5.2/Makefile.inc   2007-08-03 04:25:57.816299546 +0200
+@@ -62,7 +62,7 @@ LDFLAGS +=    -Wl,-export-dynamic 
+ endif
+ # options to save space on small systems
+-DEFINES +=      -DSUPPORT_OLD_PLUGIN_VERSIONS=1
++CFLAGS +=      -DSUPPORT_OLD_PLUGIN_VERSIONS=1
+ # search sources and headers in current dir and in src/
+ SRCS =         $(wildcard src/*.c)
+@@ -102,7 +102,7 @@ endif
+ CFLAGS +=      -MD
+ # we always need the includes and defines
+-CFLAGS += $(INCLUDES) $(DEFINES)
++CFLAGS +=      $(INCLUDES)
+ TAGFILE ?=     src/TAGS