adds tctool for controlling dsl modems, thanks Maik Zumstrull fixes #2402
authorJohn Crispin <john@openwrt.org>
Mon, 28 Jul 2008 16:52:43 +0000 (16:52 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 28 Jul 2008 16:52:43 +0000 (16:52 +0000)
SVN-Revision: 11972

net/tctool/Makefile [new file with mode: 0644]
net/tctool/patches/001_Makefile_fix.diff [new file with mode: 0644]

diff --git a/net/tctool/Makefile b/net/tctool/Makefile
new file mode 100644 (file)
index 0000000..47eff62
--- /dev/null
@@ -0,0 +1,37 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=tctool
+PKG_VERSION:=0.9.7
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
+PKG_SOURCE_URL:=http://download2.berlios.de/speedmodem50b
+PKG_MD5SUM:=df38334206d4cad106e58bd71c6f1d9a
+PKG_CAT:=unzip
+
+PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/tctool
+       SECTION:=net
+       CATEGORY:=Network
+       TITLE:=TrendChip-Modem-Utility
+       URL:=http://speedmodem50b.berlios.de/
+       DEPENDS:=+libstdcpp
+endef
+
+define Package/tctool/description
+       tcTool provides access to the console-service of TrendChip-based ADSL-Modems.
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR)/src $(TARGET_CONFIGURE_OPTS) tctool
+endef
+
+define Package/tctool/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/tctool $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,tctool))
diff --git a/net/tctool/patches/001_Makefile_fix.diff b/net/tctool/patches/001_Makefile_fix.diff
new file mode 100644 (file)
index 0000000..ee7c4f5
--- /dev/null
@@ -0,0 +1,30 @@
+diff -ur tctool.old/src/Makefile tctool/src/Makefile
+--- tctool.old/src/Makefile    2007-01-03 02:32:24.000000000 +0100
++++ tctool/src/Makefile        2007-09-18 19:15:03.068155702 +0200
+@@ -31,16 +31,16 @@
+ EXAMPLE  := example
+ EXOBJ    := if.o interface.o etherStream.o etherStreambuf.o tcStream.o tcStreambuf.o tcRtsDump.o tcRtsDumpbuf.o
+-CXX        := g++
+-CXXFLAGS   := -march=i386 -O2
+-LDFLAGS    := --strip-unneeded
+-LIBS       := 
+-LDSTATIC   := -L. -static-libgcc
+-STATICLIBS := stdc++ m
+-COUNTRY    := "C"
+-LANG       := "C"
+-LANGUAGE   := "C"
+-LC_ALL     := "C"
++#CXX        := g++
++#CXXFLAGS   := -march=i386 -O2
++#LDFLAGS    := --strip-unneeded
++#LIBS       := 
++#LDSTATIC   := -L. -static-libgcc
++#STATICLIBS := stdc++ m
++#COUNTRY    := "C"
++#LANG       := "C"
++#LANGUAGE   := "C"
++#LC_ALL     := "C"
+ default: install