[Packages] utils/hdparm: Update to 8.1
authorOliver Ertl <oliver@ertl-net.net>
Mon, 18 Feb 2008 10:57:19 +0000 (10:57 +0000)
committerOliver Ertl <oliver@ertl-net.net>
Mon, 18 Feb 2008 10:57:19 +0000 (10:57 +0000)
SVN-Revision: 10483

utils/hdparm/Makefile
utils/hdparm/patches/100-compile-fix.patch [new file with mode: 0644]

index 4704a6a93f778c1fa14efe22a67ac85e9970c472..2a201b7db00f0029a7c373b1e47dd69c0423656d 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hdparm
-PKG_VERSION:=6.6
+PKG_VERSION:=8.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/hdparm
-PKG_MD5SUM:=ecea69f775396e4ab6112dcf9066239f
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=87c1512497195204034503665f71f5fc
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -33,19 +31,13 @@ define Package/hdparm/description
        Primary use is for enabling irq-unmasking and IDE multiplemode.
 endef
 
-define Build/Configure
-endef
-
-define Build/Compile
-       $(call Build/Compile/Default, \
-               CFLAGS="$(EXTRA_CFLAGS)" \
-               LDFLAGS="$(EXTRA_LDFLAGS)" \
-       )
-endef
+MAKE_FLAGS += \
+       CFLAGS="$(EXTRA_CFLAGS)" \
+       LDFLAGS="$(EXTRA_LDFLAGS)" \
 
 define Package/hdparm/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hdparm $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin
 endef
 
 $(eval $(call BuildPackage,hdparm))
diff --git a/utils/hdparm/patches/100-compile-fix.patch b/utils/hdparm/patches/100-compile-fix.patch
new file mode 100644 (file)
index 0000000..aebc98b
--- /dev/null
@@ -0,0 +1,13 @@
+Index: hdparm-8.1/Makefile
+===================================================================
+--- hdparm-8.1.orig/Makefile   2008-02-18 11:41:31.000000000 +0100
++++ hdparm-8.1/Makefile        2008-02-18 11:41:55.000000000 +0100
+@@ -26,7 +26,7 @@
+ hdparm: hdparm.h sgio.h $(OBJS)
+       $(CC) $(LDFLAGS) -o hdparm $(OBJS)
+-      strip hdparm
++      $(STRIP) hdparm
+ sgio.o:       sgio.h