mvebu: copy the initramfs files to the bin dir
authorImre Kaloz <kaloz@openwrt.org>
Mon, 13 Apr 2015 20:06:47 +0000 (20:06 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Mon, 13 Apr 2015 20:06:47 +0000 (20:06 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 45421

target/linux/mvebu/image/Makefile

index 0d75e30eda42d46a69e96b490c0487c64665c2b4..e6e752917159598de5e0ea3242dff8c308940722 100644 (file)
@@ -14,8 +14,6 @@ JFFS2_BLOCKSIZE = 128k
 KDIR_TMP:=$(KDIR)/tmp
 
 
-UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage
-
 define Image/Build/DTB
        cp $(KDIR)/zImage$(2) $(KDIR)/zImage$(2)-$(1);
        cat $(DTS_DIR)/$(1).dtb >> $(KDIR)/zImage$(2)-$(1);
@@ -44,6 +42,7 @@ define NANDProfile
 
   define Image/Build/Profile/$(1)/Initramfs
        $(call Image/Build/DTB,$(2),-initramfs)
+       cp $(KDIR)/uImage-initramfs-$(2) $(BIN_DIR)/$(IMG_PREFIX)-$(2)-initramfs
   endef
 
   define Image/Build/Profile/$(1)/squashfs